Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Automatic Tentacle Upgrade won't work if 4.7.2 or later is not installed on the target server #5763

Closed
droyad opened this issue Aug 6, 2019 · 2 comments

Comments

@droyad
Copy link
Contributor

commented Aug 6, 2019

If the automated Tentacle upgrade is run against a target machine that does not have .NET 4.7.2 installed, it will fail. The upgrade looks for a output file for 15 minutes.

.NET 4.7.2 should not be required because the minimum required for Tentacle is .NET 4.5.

Investigation

The cause is that Octopus.Upgrader, the tool we use to orchestrate the automatic Tentacle upgrade, has been accidentally changed to require .NET 4.7.2.

Remediation

  • Make the Octopus.Upgrader work in the same support matrix as Tentacle supports (again).
  • Improve the automatic upgrade process to catch and make this failure scenario more obvious.

Workaround

Option 1: Manually install .NET 4.7.2 on the target machine allowing the automatic upgrade process to succeed.
Option 2. Manually upgrade Tentacle on the target machine without installing .NET 4.7.2 on that machine since it is not really required.

@droyad

This comment has been minimized.

Copy link
Contributor Author

commented Aug 6, 2019

@droyad droyad added the size/tiny label Aug 6, 2019

@michaelnoonan michaelnoonan changed the title Tentacle Upgrade won't work if 4.6.2 or later is not installed Automatic Tentacle Upgrade won't work if 4.6.2 or later is not installed Aug 9, 2019

@michaelnoonan michaelnoonan changed the title Automatic Tentacle Upgrade won't work if 4.6.2 or later is not installed Automatic Tentacle Upgrade won't work if 4.6.2 or later is not installed on the target server Aug 9, 2019

@michaelnoonan michaelnoonan changed the title Automatic Tentacle Upgrade won't work if 4.6.2 or later is not installed on the target server Automatic Tentacle Upgrade won't work if 4.7.2 or later is not installed on the target server Aug 9, 2019

@octoreleasebot octoreleasebot added this to the 2019.7.8 milestone Aug 12, 2019

@octoreleasebot

This comment has been minimized.

Copy link

commented Aug 12, 2019

Release Note: Fixed issue where Tentacle Upgrades fail on servers that do not have .Net Framework 4.7.2

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.