Skip to content
Permalink
Browse files

Bump up babel-cli version to fix security alert (#3121)

* Bump up babel version

* Update samples

bin/javascript-flowtyped-petstore.sh

* The dependency `babel-preset-react-app` requires `NODE_ENV` or `BABEL_ENV`

* Run `env BABEL_ENV=development npm run build` to update the samples
  • Loading branch information...
ackintosh authored and wing328 committed Jun 8, 2019
1 parent 6c98046 commit 2a5a2723002e28e1f994e7078a77e8bdd22adaec
@@ -18,7 +18,8 @@ Module system
To build an compile the flow typed sources to javascript use:
```
npm install
npm run build
# The dependency `babel-preset-react-app` requires that you specify `NODE_ENV` or `BABEL_ENV` environment variables
env BABEL_ENV={YOUR_ENV} npm run build
```

### Publishing
@@ -1,4 +1,9 @@
{
"presets": ["react-app"],
"plugins": ["transform-flow-strip-types"]
"presets": [
"react-app",
"@babel/preset-flow"
],
"plugins": [
"@babel/plugin-transform-flow-strip-types"
]
}
@@ -27,10 +27,11 @@
"portable-fetch": "^3.0.0"
},
"devDependencies": {
"babel-cli": "^6.26.0",
"babel-core": "^6.26.3",
"babel-plugin-transform-flow-strip-types": "^6.22.0",
"babel-preset-react-app": "^3.1.1",
"@babel/cli": "^7.0.0",
"@babel/core": "^7.0.0",
"@babel/plugin-transform-flow-strip-types": "^7.0.0",
"@babel/preset-flow": "^7.0.0",
"babel-preset-react-app": "^7.0.0",
"flow-copy-source": "^1.3.0",
"rimraf": "^2.6.2"
}
@@ -1,4 +1,9 @@
{
"presets": ["react-app"],
"plugins": ["transform-flow-strip-types"]
"presets": [
"react-app",
"@babel/preset-flow"
],
"plugins": [
"@babel/plugin-transform-flow-strip-types"
]
}
@@ -1 +1 @@
4.0.0-SNAPSHOT
4.0.2-SNAPSHOT
@@ -18,7 +18,8 @@ Module system
To build an compile the flow typed sources to javascript use:
```
npm install
npm run build
# The dependency `babel-preset-react-app` requires that you specify `NODE_ENV` or `BABEL_ENV` environment variables
env BABEL_ENV={YOUR_ENV} npm run build
```

### Publishing

0 comments on commit 2a5a272

Please sign in to comment.
You can’t perform that action at this time.