Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update (broken) Vagrant configuration. #1156

Merged
merged 2 commits into from Oct 5, 2018
Merged

Update (broken) Vagrant configuration. #1156

merged 2 commits into from Oct 5, 2018

Conversation

@mknoszlig
Copy link
Contributor

@mknoszlig mknoszlig commented Oct 1, 2018

PR checklist

  • Read the contribution guidelines.
  • Ran the shell script under ./bin/ to update Petstore sample so that CIs can verify the change. (For instance, only need to run ./bin/{LANG}-petstore.sh and ./bin/security/{LANG}-petstore.sh if updating the {LANG} (e.g. php, ruby, python, etc) code generator or {LANG} client's mustache templates). Windows batch files can be found in .\bin\windows\.
  • Filed the PR against the correct branch: master (3.3.x), 4.0.x. Default: master.
  • Copied the technical committee to review the pull request if your PR is targeting a particular programming language.

Description of the PR

Updated the included Vagrantfile to install a current ubuntu version. Also updated the referred apt repo and keys to ones that are available. With these changes i was able to create a build following the Instructions in the readme (1.6 Docker -> in Vagrant). Hope this will save somebody else some time.

Cheers.

@wing328
Copy link
Member

@wing328 wing328 commented Oct 4, 2018

@mknoszlig thanks for the PR. I'll try to find some time tomorrow to test it and hopefully merge it over the weekend.

Loading

@wing328 wing328 added this to the 3.3.1 milestone Oct 4, 2018
@wing328
Copy link
Member

@wing328 wing328 commented Oct 5, 2018

Tested locally in my Mac. I was able to repeat the issue and confirmed the fix.

Loading

@wing328 wing328 merged commit 9939702 into OpenAPITools:master Oct 5, 2018
4 checks passed
Loading
@wing328
Copy link
Member

@wing328 wing328 commented Oct 5, 2018

@mknoszlig thanks for the PR, which has been merged into master.

Quick question if you don't mind - do I need to run vagrant box add ubuntu/bionic64 manually? or likely there's something wrong with the setup of Vagrant in my machine?

Loading

@mknoszlig
Copy link
Contributor Author

@mknoszlig mknoszlig commented Oct 5, 2018

@wing328 Glad to help!

re your question: according to the docs, the box should be added automatically (https://www.vagrantup.com/intro/getting-started/boxes.html#using-a-box) when running vagrant up or similar - did you per chance get any error message related to the missing box?

Loading

@wing328
Copy link
Member

@wing328 wing328 commented Oct 5, 2018

@mknoszlig I didn't get any error as it's using the default image. My guess is that it's due to Vagrant setup/installation issue in my machine.

Loading

mwoodland pushed a commit to mwoodland/openapi-generator that referenced this issue Oct 9, 2018
@wing328
Copy link
Member

@wing328 wing328 commented Oct 16, 2018

@mknoszlig thanks again for the fix, which has been included in the v3.3.1 release: https://twitter.com/oas_generator/status/1052020299821080577

Loading

A-Joshi pushed a commit to ihsmarkitoss/openapi-generator that referenced this issue Feb 27, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants