gpio not supported anymore for raspberry pi 2 #3908

Closed
just4fun73de opened this Issue Feb 11, 2015 · 3 comments

Projects

None yet

5 participants

@just4fun73de

i use lirc for my remote control on raspberry pi 2.

but with the new rasp lirc isnt supported anymore.

see: dmesg | grep lirc --> emtpy list

OpenELEC:~ # modprobe lirc_rpi
modprobe: ERROR: could not insert 'lirc_rpi': No such device

OpenELEC:~ # dmesg | grep lirc
[ 1033.769079] lirc_dev: IR Remote Control driver registered, major 248
[ 1033.778591] lirc_rpi: module is from the staging directory, the quality is unknown, you have been warned.
[ 1033.780826] lirc_rpi: gpio chip not found!

Alex

@popcornmix

You should use the forums for questions like this.
But, read: https://github.com/raspberrypi/firmware/blob/master/boot/overlays/README

Add to config.txt
dtoverlay=lirc-rpi

@loisaidasam

I experienced the same issue, and in case anyone else ends up here and doesn't know, "config.txt" refers to /boot/config.txt

(adding dtoverlay=lirc-rpi solved the issue for me 👍)

@aHcVolle

this did work! thanks

@lrusak lrusak locked and limited conversation to collaborators Oct 21, 2015
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.