Inlines not evaled if a script is not included #44

Closed
markhealey opened this Issue Mar 8, 2013 · 2 comments

Comments

Projects
None yet
2 participants
@markhealey
Member

markhealey commented Mar 8, 2013

Thanks Quentin. Looks like inlineScripts included in the AppManifest are not evaluated if there are no scripts defined.

Recommended fix is to add evalInlines() to this block:

https://github.com/OpenF2/F2/blob/master/sdk/src/container.js#L239

// if no scripts were to be processed, fire the appLoad event if (!scriptCount) { evalInlines(); appInit(); }

@ghost ghost assigned brianbaker Mar 8, 2013

@brianbaker

This comment has been minimized.

Show comment
Hide comment
@brianbaker

brianbaker Mar 13, 2013

Member

Certainly will be an easy fix, but its also a somewhat odd request. What is the use case for an AppManifest that has only inlineScripts but no scripts? Seems like that would mean the app is not using an App Class and going against the spec's recommendation for Inline Scripts

Member

brianbaker commented Mar 13, 2013

Certainly will be an easy fix, but its also a somewhat odd request. What is the use case for an AppManifest that has only inlineScripts but no scripts? Seems like that would mean the app is not using an App Class and going against the spec's recommendation for Inline Scripts

@markhealey

This comment has been minimized.

Show comment
Hide comment
@markhealey

markhealey Mar 14, 2013

Member

This definitely goes against the recommendations in the spec for inlineScripts. I just got off the phone with another developer who reported this same problem, so apparently there is a need for this functionality.

Member

markhealey commented Mar 14, 2013

This definitely goes against the recommendations in the spec for inlineScripts. I just got off the phone with another developer who reported this same problem, so apparently there is a need for this functionality.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment