Browser Compatibility

markhealey edited this page Sep 25, 2014 · 6 revisions

While developing F2.js, it's an important goal of ours to ensure browser compatibility across the major (and minor) browsers. Of course, creating—and iterating on—a complex and modern web integration framework means taking a forward-thinking approach.

Browser Support

The following browser versions are supported by the latest release of F2.js:

Google Chrome 25+

Microsoft Internet Explorer 8+

Mozilla Firefox 7+

Opera 11+

Apple Safari 5+

For Bootstrap JS and CSS browser support, browse to their Getting Started section.

Unofficially, F2.js is known to function as expected in IE7 and we have been fixing issues as they are reported (e.g., see #101).

Issues

If you encounter any browser-specific issues with F2.js, submit a new Issue on GitHub.