Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Shouldn't the PHP requirement be raised to 5.4? #412

Closed
barbazul opened this issue Dec 14, 2017 · 14 comments

Comments

8 participants
@barbazul
Copy link

commented Dec 14, 2017

Magento 1.9.x officially supports only 5.4, 5.5 and 5.6 http://docs.magento.com/m1/ce/user_guide/magento/system-requirements.html

Current composer.json file requires PHP >= 5.2.13

Magento clearly would not work on PHP 5.2 nor there should be anyone out there still using 5.2

@alcipir

This comment has been minimized.

Copy link

commented Dec 22, 2017

Definitely, is there any reason not to raise the required version on the composer file?

@barbazul

This comment has been minimized.

Copy link
Author

commented Dec 22, 2017

I dare say we should raise it to 5.6 since 5.4 and 5.5 are no longer supported by PHP, but that's another story

@alcipir

This comment has been minimized.

Copy link

commented Dec 22, 2017

And why not 7? Seriously, the performance gains are enormous, I really wanted to know the rationale behind still supporting PHP 5.6

@colinmollenhour

This comment has been minimized.

Copy link
Contributor

commented Dec 22, 2017

Technically there are commercial organizations supporting PHP 5.4 and up. For example Debian 7 is EOL in May 2018 and uses PHP 5.4 and Ubuntu 14.04 LTS is EOL in April 2019 and uses PHP 5.5. I think CentOS 6 is still supporting PHP 5.3. I don't recommend running any of these but just because the official PHP ends support doesn't mean that support has completely ended across the board.

However, I would also consider this project to be more of a "power-user" derivative and think that dropping support for old versions and even making PHP 7 the minimum would not be unreasonable. As @alcipir said PHP 7 is so much faster that running on 5.x is basically inexcusable. Also with Docker now it is a piece of cake to run the latest version of PHP on just about any machine (as long as it is 64bit and not too old of a kernel).

@barbazul

This comment has been minimized.

Copy link
Author

commented Dec 24, 2017

To raise the requirement to 7 would mean to also include the corresponding compatibility fixes which might fall a little outside of this project scope, but you would definitely not hear any complaints from me if this happens

@sreichel sreichel added the Question label Jan 11, 2018

@sreichel

This comment has been minimized.

Copy link
Collaborator

commented Jan 14, 2018

To raise the requirement to 7 would mean to also include the corresponding compatibility fixes which might fall a little outside of this project scope,

PHP7 fixes are in since 1.9.2.x.

Does it makes sense (are there any advantages?) to raise min. requrierment. Current code also works with 5.3 ... IMHO, this is only required, when/if we start adding features like Aoe_Layout code that requires 5.5+.

@colinmollenhour

This comment has been minimized.

Copy link
Contributor

commented Jan 17, 2018

The advantages would be that we would have less backwards compatibility to worry about going forward, we could use new things like ?? operator, array_column (5.5+), etc. I don't think we should try to adopt things like traits that are core design features or go back and rewrite tons of code to use these new features, just allow the use of the little improvements going forward.

@barbazul

This comment has been minimized.

Copy link
Author

commented Jan 18, 2018

I think 5.3 should be deprecated, no questions asked. Magento officially does not support that version, then this open fork should not support it either (since there is also no real benefit or reason for doing so).

Raising it above 5.4 (the official Magento minimum) is a matter that does deserve further discussion. My position is that there is benefit in not having to support really old versions of PHP and also raising awareness about not running an ecommerce solution in unsupported, unmaintained, unsecure platforms.

That said, I would not raise the minimum above 5.6 under any circumstance.

@tomekjordan

This comment has been minimized.

Copy link

commented Jan 18, 2018

As a merchant I will say. discussion is pointless. I used 5.6 - two years ago. So 5.6 as total minimum. nobody cares about 5.3, 5.4 5.5. LTS is a project for people who knows what to do. so dont bother and raise it at least to 5.6

@colinmollenhour

This comment has been minimized.

Copy link
Contributor

commented Jan 19, 2018

So there are some objections to 7 being the minimum. Just to put this at rest for now (will eventually take care of itself as more versions hit EOL) I suggest as a compromise we set PHP 5.5.9 as the minimum (while it is EOL, it is supported by Ubuntu 14.04 LTS which could still be in widespread use).

So any objection to this?

"php": ">=5.5.9",
@barbazul

This comment has been minimized.

Copy link
Author

commented Jan 20, 2018

Sounds about right

@sreichel sreichel added this to To Do in Project Cleanup Jan 28, 2018

@sreichel sreichel moved this from To Do to In progress in Project Cleanup Jan 31, 2018

@lfluvisotto

This comment has been minimized.

Copy link
Contributor

commented Mar 24, 2018

colinmollenhour referenced this issue Oct 9, 2018

Update README with Requirements section and other improvements. (#507)
* Update README with Requirements section and other improvements. Refs #105

* Update composer with supported PHP versions.
@corbinu

This comment has been minimized.

Copy link

commented Nov 13, 2018

@colinmollenhour given Ubuntu 14.04 EOF is April I would say raise it to 5.5.9 now. Then in April raise it to 7.0 since thats the version in Ubuntu 16.04

@sreichel

This comment has been minimized.

Copy link
Collaborator

commented Apr 15, 2019

PHP5.6 is EOL since beginning of this year ... so i'd raise minimum requirements to PHP7 at least.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.