Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[CLI] Dataset update GraphQL error: internal service error #1299

Open
franklin-feingold opened this issue Sep 27, 2019 · 2 comments · Fixed by #1380

Comments

@franklin-feingold
Copy link
Contributor

@franklin-feingold franklin-feingold commented Sep 27, 2019

A user is trying to update their dataset. The API key works and the CLI identifies the existing files. When trying to add new files to the dataset this error occurs:

(node:6019) UnhandledPromiseRejectionWarning: Error: GraphQL error: Internal Server Error
    at new ApolloError (/usr/local/lib/node_modules/openneuro-cli/node_modules/apollo-client/bundle.umd.js:92:26)
    at Object.next (/usr/local/lib/node_modules/openneuro-cli/node_modules/apollo-client/bundle.umd.js:1296:31)
    at notifySubscription (/usr/local/lib/node_modules/openneuro-cli/node_modules/zen-observable/lib/Observable.js:130:18)
    at onNotify (/usr/local/lib/node_modules/openneuro-cli/node_modules/zen-observable/lib/Observable.js:165:3)
    at SubscriptionObserver.next (/usr/local/lib/node_modules/openneuro-cli/node_modules/zen-observable/lib/Observable.js:219:7)
    at /usr/local/lib/node_modules/openneuro-cli/node_modules/apollo-client/bundle.umd.js:1101:36
    at Set.forEach (<anonymous>)
    at Object.next (/usr/local/lib/node_modules/openneuro-cli/node_modules/apollo-client/bundle.umd.js:1100:21)
    at notifySubscription (/usr/local/lib/node_modules/openneuro-cli/node_modules/zen-observable/lib/Observable.js:130:18)
    at onNotify (/usr/local/lib/node_modules/openneuro-cli/node_modules/zen-observable/lib/Observable.js:165:3)
(node:6019) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:6019) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

This error is hit before the new files are readout on the command line as being processed for uploading

The user has also shared the full command line output

@franklin-feingold franklin-feingold changed the title Dataset update GraphQL error: internal service error [CLI] Dataset update GraphQL error: internal service error Sep 27, 2019
@ckrountree

This comment has been minimized.

Copy link

@ckrountree ckrountree commented Nov 5, 2019

Make sure that the user is using the most up-to-date node.js (v10).

@franklin-feingold

This comment has been minimized.

Copy link
Contributor Author

@franklin-feingold franklin-feingold commented Nov 19, 2019

updating node did not fix this issue

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.