New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Compiling and Building Documentation Bug #15867

Open
JColstrom opened this Issue Nov 30, 2018 · 0 comments

Comments

Projects
None yet
3 participants
@JColstrom

JColstrom commented Nov 30, 2018

Issue Summary

While attempting to contribute to OpenRA with some friends, we found an issue in the original Compiling and Building documentation. There was a missing step for adding an adapter in order to run tests in the test suite.

System Information

  • Windows 10
  • Visual Studio 2017

Additional Information:

  • Steps to reproduce
    1. Follow the steps to download and install the source code from a base level (no previous
      installation) found here:
      https:// github.com/OpenRA/OpenRA/wiki/Compiling
      2. Build the game in Visual Studio 2017.
      3. Open the Test Suite using the top menu bar, Test -> Windows -> Test Explorer.
      4. Try to run all tests. (this will fail due to missing adapter)

Solution!

The solution to this issue is actually pretty simple, even though it was pretty difficult to find originally. In the solution explorer which should be on the right hand side, right-click the solution name and choose Manage NuGet Packages for this Solution. In the NuGet - Solution tab, in the Browse tab, search for "Nunit3TestAdapter" and install it. Doing this will allow the test suite to run perfectly fine but this was missing from any documentation.

Please add this solution to the Compiling documentation directly underneath "If you'd like to edit or compile the source code using Visual Studio:" in one of the bullet points (Within the 'Windows' section).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment