Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fatal Error #17258

Open
siriusthewolf opened this issue Oct 19, 2019 · 8 comments
Labels

Comments

@siriusthewolf
Copy link

@siriusthewolf siriusthewolf commented Oct 19, 2019

Tried OpenRa for the first time.
Downloaded the game using PowerShell following the instructions in INSTAL.MD
Tried: launch-game.cmd Game.Mod=ra

RESULT:
System.AccessViolationException
em System.Buffer.Memmove(Byte* dest, Byte* src, UInt64 len)
em System.Buffer.Memcpy(Byte* pDest, Int32 destIndex, Byte[] src, Int32 srcIndex, Int32 len)
em OpenRA.Platforms.Default.Sdl2GraphicsContext.DrawPrimitives(PrimitiveType pt, Int32 firstVertex, Int32 numVertices)
em OpenRA.Renderer.DrawBatch[T](IVertexBuffer`1 vertices, Int32 firstVertex, Int32 numVertices, PrimitiveType type)
em OpenRA.Graphics.SpriteRenderer.Flush()
em OpenRA.Renderer.EndFrame(IInputHandler inputHandler)
em OpenRA.Mods.Common.LoadScreens.ModContentLoadScreen.Display()
em OpenRA.ModData..ctor(Manifest mod, InstalledMods mods, Boolean useLoadScreen)
em OpenRA.Game.InitializeMod(String mod, Arguments args)
em OpenRA.Mods.Common.LoadScreens.BlankLoadScreen.BeforeLoad()
em OpenRA.Game.InitializeMod(String mod, Arguments args)
em OpenRA.Game.Initialize(Arguments args)
em OpenRA.Game.InitializeAndRun(String[] args)
em OpenRA.Program.Main(String[] args)

OpenRA has encountered a fatal error.

Couldn't find any log File Available

@pchote

This comment has been minimized.

Copy link
Member

@pchote pchote commented Oct 19, 2019

There are several things we will need to know before we can help:

  • What version of OpenRA are you trying to run?
  • What version of Windows are you using?
  • What version(s) of the .NET framework do you have installed?
  • What GPU and drivers are installed?
@abcdefg30 abcdefg30 added the Crash label Oct 19, 2019
@siriusthewolf

This comment has been minimized.

Copy link
Author

@siriusthewolf siriusthewolf commented Oct 19, 2019

There are several things we will need to know before we can help:

  • What version of OpenRA are you trying to run?
    ----playtest-20190825
  • What version of Windows are you using?
    ---- Win10 ver. 1809
  • What version(s) of the .NET framework do you have installed?
    ---- .NET Core 3.0.100 SDK/.NET framework 4.6.1 (Developer Pack)
  • What GPU and drivers are installed?
    ---- Intel(R) HD Graphics 4000/ WDDM 1.3
@matjaeck

This comment has been minimized.

Copy link
Contributor

@matjaeck matjaeck commented Oct 19, 2019

@siriusthewolf

This comment has been minimized.

Copy link
Author

@siriusthewolf siriusthewolf commented Oct 19, 2019

Have you tried the executable from https://github.com/OpenRA/OpenRA/releases/tag/playtest-20190825?

It works.
But shouldn't I be able to launch the game following the instructions in INSTALL.md?

@matjaeck

This comment has been minimized.

Copy link
Contributor

@matjaeck matjaeck commented Oct 19, 2019

It works.

So you can start the game after installing it?

But shouldn't I be able to launch the game following the instructions in INSTALL.md?

Yes, it should be possible. Can you double check, navigate to the OpenRA directory with your console and follow the instructions here https://github.com/OpenRA/OpenRA/wiki/Compiling#windows?

@siriusthewolf

This comment has been minimized.

Copy link
Author

@siriusthewolf siriusthewolf commented Oct 19, 2019

Double checked:
FatalError
I can start the game if I use the .exe but if I try using command line it throws the failure above.

Detail:
The .exe version wasn't installed in the default directory (C:/ - don't know if this matters)

Observation:
I get an error in my language - > Exception without treatment: System.AccesViolationException: Attempt of reading or recording in protected memory. Normally, this is a indication that another memory is damaged. (Second Paragraph in the image)

@matjaeck

This comment has been minimized.

Copy link
Contributor

@matjaeck matjaeck commented Oct 19, 2019

Thanks for trying it again. I think we confirmed that you did everything correctly and still have the issue.

@siriusthewolf

This comment has been minimized.

Copy link
Author

@siriusthewolf siriusthewolf commented Oct 19, 2019

Well, I hope I did everuthying.
This is pretty much my first attempt working with git

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.