Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RA - Add new Bridges and make them use proper HitShapes #15322

Closed
wants to merge 1 commit into from

Conversation

@MustaphaTR
Copy link
Member

MustaphaTR commented Jul 4, 2018

Revived #14499. This one only adds NW-SE diagonal ones, as others were buggy. But this time includes one for desert tileset too.

@Mailaender

This comment has been minimized.

Copy link
Member

Mailaender commented Sep 12, 2018

Something seems to be wrong with the NW-SE bridge huts (Tanya C4 doesn't work on them) and their rendering geometry, which isn't displayed:
openra-2018-09-12t143031704z

@MustaphaTR MustaphaTR force-pushed the MustaphaTR:ra-long-bridges-2 branch from 8e4e6aa to 149e45c Sep 13, 2018
@MustaphaTR

This comment has been minimized.

Copy link
Member Author

MustaphaTR commented Sep 13, 2018

Updated, seems like i forgot to push changes to world.yaml somehow.

@Mailaender

This comment has been minimized.

Copy link
Member

Mailaender commented Sep 13, 2018

It looks like the bridge hut location needs to move as the destroyed ones don't let engineers enter:

openra-2018-09-13t130145097z

@MustaphaTR MustaphaTR force-pushed the MustaphaTR:ra-long-bridges-2 branch from 149e45c to 4da8264 Sep 30, 2018
@MustaphaTR

This comment has been minimized.

Copy link
Member Author

MustaphaTR commented Sep 30, 2018

Updated. I moved top hut for NW-SE 1 cell to the left, added CombatDebugOverlay trait. Everything seem to work on my end.

@netnazgul

This comment has been minimized.

Copy link
Contributor

netnazgul commented Oct 4, 2018

Looks like sometimes adjacent tile doesn't change to damaged like it is supposed to
image

image

Also top edge diagonal is crossable between the beach and the bridge, but this is the problem for sw-ne bridge as well.

Otherwise fine for me, will do non-temperate tileset tests later also.

Copy link
Contributor

netnazgul left a comment

Looks like sometimes adjacent tile doesn't change to damaged like it is supposed to

@pchote

This comment has been minimized.

Copy link
Member

pchote commented Mar 9, 2019

@MustaphaTR are you planning to revisit this? If not, can you please close this?

@pchote pchote added this to the Future milestone Apr 21, 2019
@pchote

This comment has been minimized.

Copy link
Member

pchote commented Apr 21, 2019

Moving to the future milestone.

@pchote pchote closed this Apr 21, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.