Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Toy factory "hammer" sometimes disconnects #51

Closed
Wuzzy2 opened this issue Feb 5, 2021 · 2 comments
Closed

Toy factory "hammer" sometimes disconnects #51

Wuzzy2 opened this issue Feb 5, 2021 · 2 comments

Comments

@Wuzzy2
Copy link

@Wuzzy2 Wuzzy2 commented Feb 5, 2021

OpenGFX 0.6.0, OpenTTD 1.9.3. Zoom 2×.

Sometimes, the toy factory "hammer" gets disconnected like so:

https://satoshiupload.com/images/osLk6aUaRB.png

I have no idea if this is an OpenGFX or an OpenTTD bug.

@nielsmh
Copy link

@nielsmh nielsmh commented Feb 5, 2021

image

@Andrew350
Copy link
Contributor

@Andrew350 Andrew350 commented Feb 5, 2021

As I said in my reply to the other issue (which seemingly got overlooked), it is simply a case of incorrect offsets in OpenGFX. Shifting the buildings to their correct locations will fix this problem and the animation disappearing early. I just haven't got around to making a PR for it yet, but it really is a 2 second fix 🙂

Andrew350 added a commit to Andrew350/OpenGFX that referenced this issue Mar 4, 2021
Andrew350 added a commit to Andrew350/OpenGFX that referenced this issue Mar 4, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

3 participants