Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Dedicated Linux OpenTTD 1.2.3 crash #5513

Closed
DorpsGek opened this Issue Mar 26, 2013 · 6 comments

Comments

Projects
None yet
1 participant
@DorpsGek
Copy link

DorpsGek commented Mar 26, 2013

TaKeN opened the ticket and wrote:

Hello
Today again one of my dedicated servers crash
I put both crash.log and crash.sav to attach.

Thanks
TaKeN

Attachments

Reported version: 1.2.3
Operating system: Linux


This issue was imported from FlySpray: https://bugs.openttd.org/task/5513
@DorpsGek

This comment has been minimized.

Copy link
Author

DorpsGek commented Mar 27, 2013

frosch wrote:

We just noticed that you compiled using GCC 4.5.

To our knowledge GCC 4.5 has a serious optimizer bug which usually causes OTTD to already crash on start-up (and is likely break many validation checks in the network code). Did you work around this obvious crash in some way? Or disabled optimisations? Or did you get the source code from some other location than openttd.org which might have worked around the start-up problem?


This comment was imported from FlySpray: https://bugs.openttd.org/task/5513#comment12119
@DorpsGek

This comment has been minimized.

Copy link
Author

DorpsGek commented Mar 27, 2013

TaKeN wrote:

Hello
Thanks for fast answer.
I got 3 servers and only this one crash - i always download source from OpenTTD webpage.
He never crash i see i compile this 11.01.2013 so that was first crash in 3 month....
I can compile with gcc version 4.6.3 - that`s help ?

Thanks


This comment was imported from FlySpray: https://bugs.openttd.org/task/5513#comment12120
@DorpsGek

This comment has been minimized.

Copy link
Author

DorpsGek commented Mar 27, 2013

frosch wrote:

Yes, please try 4.6.

It crashed in the same place as in your previous report, and we had no other similar reports.
Though I wonder why your OTTD does not crash on start-up :p

For reference:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43680


This comment was imported from FlySpray: https://bugs.openttd.org/task/5513#comment12121
@DorpsGek

This comment has been minimized.

Copy link
Author

DorpsGek commented Mar 27, 2013

TaKeN wrote:

Hehhe Openttd start with no problem and working for last 3 month ;-)
I wait for OpenTTD 1.3.0 stable and i compile with 4.6 :)
Thanks for help


This comment was imported from FlySpray: https://bugs.openttd.org/task/5513#comment12122
@DorpsGek

This comment has been minimized.

Copy link
Author

DorpsGek commented Mar 28, 2013

TaKeN wrote:

This is impossible i today wake up and i see one of my server not start like You say...
I just compile OpenTTD 1.2.3 with GCC 4.6.3 hope that`s help.
Thanks


This comment was imported from FlySpray: https://bugs.openttd.org/task/5513#comment12124
@DorpsGek

This comment has been minimized.

Copy link
Author

DorpsGek commented Jun 23, 2013

frosch closed the ticket.

Reason for closing: Unreproducible

likely due to gcc 4.5


This comment was imported from FlySpray: https://bugs.openttd.org/task/5513
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.