Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Crash when no baseset en invalid font in configuration #6226

Closed
DorpsGek opened this issue Feb 4, 2015 · 2 comments
Closed

Crash when no baseset en invalid font in configuration #6226

DorpsGek opened this issue Feb 4, 2015 · 2 comments

Comments

@DorpsGek
Copy link

@DorpsGek DorpsGek commented Feb 4, 2015

roidal opened the ticket and wrote:

Version:
Linux 1.4.4 64 bit

What happens:
Segfault if there is no graphic-set available (first start)

How to bypass:
Manually copy opengfx-0.5.0.tar into the ~/.openttd/baseset directory

Additional to the attached crash.log there are few error-lines at STDOUT:

./openttd
Unable to use '/usr/share/fonts/adobe-source-han-sans-twhk/SourceHanSansTW-Heavy.otf' for medium font, FreeType reported error 0x1, using sprite font instead
Unable to use '/usr/share/fonts/adobe-source-han-sans-twhk/SourceHanSansTW-Heavy.otf' for small font, FreeType reported error 0x1, using sprite font instead
Unable to use '/usr/share/fonts/adobe-source-han-sans-twhk/SourceHanSansTW-Heavy.otf' for large font, FreeType reported error 0x1, using sprite font instead

Attachments

Reported version: 1.4.4
Operating system: Linux


This issue was imported from FlySpray: https://bugs.openttd.org/task/6226
@DorpsGek

This comment has been minimized.

Copy link
Author

@DorpsGek DorpsGek commented Feb 4, 2015

frosch wrote:

There are two features in conflict here:
* If no baseset is installed, OTTD tries to not use the sprite font, but a system supplied font instead.
* If the system font set via openttd.cfg (SourceHanSansTW-Heavy) is invalid, it falls back to the sprite font.

Likely these two fallbacks need to be reversed, or iterated twice.


This comment was imported from FlySpray: https://bugs.openttd.org/task/6226#comment13758
@TrueBrain TrueBrain changed the title Crash: [Linux] missing graphic-set Crash when no baseset en invalid font in configuration Apr 12, 2018
@frosch123 frosch123 removed the Core label Apr 14, 2018
@andythenorth andythenorth added the stale label Jan 5, 2019
@andythenorth

This comment has been minimized.

Copy link
Contributor

@andythenorth andythenorth commented Jan 9, 2019

Thanks for this. At the time of writing this appears to be an isolated bug, and not frequently reported. We do try to address bugs where they occur frequently and/or are easy to reproduce, but this one doesn't look like we can any go further, so I'm closing it. Thanks for contributing!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants
You can’t perform that action at this time.