Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Presignal doesn't work on long distance #7087

Closed
ale84s opened this issue Jan 23, 2019 · 7 comments
Closed

Presignal doesn't work on long distance #7087

ale84s opened this issue Jan 23, 2019 · 7 comments

Comments

@ale84s
Copy link

@ale84s ale84s commented Jan 23, 2019

Presignal become green altough signal exit is red on long distance.
presignal-not-work

@ale84s ale84s changed the title Presignal not work on long distance Presignal doesn't work on long distance Jan 23, 2019
@Eddi-z
Copy link
Contributor

@Eddi-z Eddi-z commented Jan 23, 2019

You have two exit signals in this block, the entry signal will only get red if BOTH are red. block signals will never work properly in such a two-way setup, and you should be using path signals instead.

IIRC there is a distance where presignals stop working, but that should be 256 tiles or something like that, nothing that should apply to your situation here

@andythenorth
Copy link
Contributor

@andythenorth andythenorth commented Jan 23, 2019

Closing, per Eddi's comments. Thanks for contributing!

@ale84s
Copy link
Author

@ale84s ale84s commented Jan 23, 2019

You have two exit signals in this block, the entry signal will only get red if BOTH are red. block signals will never work properly in such a two-way setup, and you should be using path signals instead.

IIRC there is a distance where presignals stop working, but that should be 256 tiles or something like that, nothing that should apply to your situation here

No, there's only one exit signal into the block, after the pre-signal: on short distance this configuration work properly, it stop working when the distance between pre-signal and exit signal increase. The railway line into the screenshot is created only to show the issue.

@planetmaker
Copy link
Contributor

@planetmaker planetmaker commented Jan 23, 2019

Can you provide a savegame which shows the behaviour?

@glx22
Copy link
Contributor

@glx22 glx22 commented Jan 23, 2019

The non reachable signal 2 tiles away is probably green, pre-signals don't check if exit signal is reachable, only the connection of the track tiles. This behaviour is often abused to make priority tracks.
https://wiki.openttd.org/Signals#Limitation

@ale84s
Copy link
Author

@ale84s ale84s commented Jan 24, 2019

Can you provide a savegame which shows the behaviour?

Nufingley Market Transport, 23 Mag 1951.zip

@andythenorth andythenorth reopened this Jan 24, 2019
@PeterN
Copy link
Member

@PeterN PeterN commented Jan 25, 2019

Your savegame confirms there are two exit signals in this block, and the one nearest Train 2 is green, as glx22 wrote. This is not a bug, this is how pre-signals work. Switch to using path signals for a solution that will work as you expect.

@PeterN PeterN closed this Jan 25, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
6 participants
You can’t perform that action at this time.