Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Station sign kd-tree is not updated if station XY changes due to acquiring an ownerless/grey station pending deletion #7374

Closed
JGRennison opened this issue Mar 13, 2019 · 0 comments
Assignees

Comments

@JGRennison
Copy link
Contributor

@JGRennison JGRennison commented Mar 13, 2019

Version of OpenTTD

master, presumably since kd-tree changes

Expected result

Viewport station sign is rendered correctly

Actual result

Viewport station sign is not rendered correctly in case described below

Steps to reproduce

  • Build a station
  • Demolish it, leaving a grey station label
  • Build a new station part using the same station at a different coordinate
  • Station sign label is now either missing for large distances or has clipping issues for small distances
@nielsmh nielsmh self-assigned this Mar 13, 2019
nielsmh added a commit to nielsmh/OpenTTD that referenced this issue Mar 23, 2019
nielsmh added a commit to nielsmh/OpenTTD that referenced this issue Mar 23, 2019
nielsmh added a commit to nielsmh/OpenTTD that referenced this issue Mar 24, 2019
@nielsmh nielsmh closed this in ce10d9b Mar 24, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.