Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Text for some railway station NewGRFs is missing/invisible #7447

Closed
buttercup5 opened this issue Mar 30, 2019 · 5 comments
Closed

Text for some railway station NewGRFs is missing/invisible #7447

buttercup5 opened this issue Mar 30, 2019 · 5 comments

Comments

@buttercup5
Copy link

@buttercup5 buttercup5 commented Mar 30, 2019

Version of OpenTTD

Working in 20190319-master-g559d4e8335; broken in 20190324-master-g37b9fdc0c1. I don't have any of the builds in between those two to narrow it down further.

Expected result

In the railway station construction window there should be a list of station tiles provided by the NewGRF(s), with accompanying preview picture.

Actual result

The text for some NewGRF station sets is not displayed, but clicking on the line where there should be text still shows a preview picture. Also, the name of the station tile isn't correct (it shows "Default station" instead).

Steps to reproduce

Load the savefile, open the railway station build window.

Other notes

Hopefully the screenshots are enough to show what I'm talking about. Not sure how useful a savefile is but I included one anyway, and it has a load more station NewGRFs - some fine, some broken.

20190319
20190324

stationtest.zip

frosch123 added a commit to frosch123/OpenTTD that referenced this issue Mar 30, 2019
@PeterN PeterN closed this in 0cf25e8 Mar 30, 2019
@eekee

This comment has been minimized.

Copy link

@eekee eekee commented Apr 1, 2019

Oh boy... It's really nice to see a bug fixed before I even spotted it, but... Will the fix be in 1.9.1? Or was today's 1.9.0 April Fools?

@nielsmh

This comment has been minimized.

Copy link
Contributor

@nielsmh nielsmh commented Apr 2, 2019

I don't think there's been any decision regarding 1.9.1 yet, whether a release will be made or not. I guess it depends on any other bugs discovered in 1.9.0 release.

@eekee

This comment has been minimized.

Copy link

@eekee eekee commented Apr 2, 2019

Oh. Well, this bug alone is somewhat serious to me. I can play cargo games because CHIPS and ISR aren't affected, but in pax games I like to build complex stations. I use the Dutch station sets, all of which are affected -- 19 consecutive blank entries! I might learn to remember a few, but it's hard.

I'm sorry I didn't load up a pax game when I returned to OTTD a few weeks ago. If I had, you would have got this bug report a lot sooner.

@LordAro

This comment has been minimized.

Copy link
Member

@LordAro LordAro commented Apr 2, 2019

The fix for this should have gone into 1.9.0, but it got forgotten. It will be in 1.9.1, which I do currently expect to happen (maybe a month or so, maybe sooner)

@eekee

This comment has been minimized.

Copy link

@eekee eekee commented Apr 2, 2019

Good to know. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.