Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Runs as windows admin from installer #7470

Closed
brunom opened this issue Apr 4, 2019 · 1 comment · Fixed by #7270
Closed

Runs as windows admin from installer #7470

brunom opened this issue Apr 4, 2019 · 1 comment · Fixed by #7270

Comments

@brunom
Copy link

@brunom brunom commented Apr 4, 2019

Version of OpenTTD

1.9.0

Expected result

openTTD should run without elevation

Actual result

openTTD runs with admin right from the isntaller

Steps to reproduce

Choose run in the last page of windows installer. Check process elevation woth process explorer.

@TrueBrain
Copy link
Member

@TrueBrain TrueBrain commented Apr 7, 2019

One would think NSIS solves this for you; seems that thinking is wrong.

We have two options here: either we remove the option, or we find out how to fix it properly. As we are switching to CMake / CPack to control NSIS, we have far less control over these things, so I am very tempted to just remove the option.
Possibly it would be good if we invest in one of the other installers .. but that is for another day.

Tnx for noticing this @brunom !

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

2 participants