Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Odd Cursor Glitch When Moving Through Windows and Game #8076

Open
CheeseSprinkles opened this issue Apr 10, 2020 · 5 comments
Open

Odd Cursor Glitch When Moving Through Windows and Game #8076

CheeseSprinkles opened this issue Apr 10, 2020 · 5 comments

Comments

@CheeseSprinkles
Copy link

@CheeseSprinkles CheeseSprinkles commented Apr 10, 2020

Version of OpenTTD

1.10.0, Linux Debian

Expected result

The cursor should behave normally in-game.

Actual result

The cursor bugs out in-game, lags significantly and creates clones of itself while moving around.

Steps to reproduce

Open any save or start a new game; move the cursor aorund.
Screenshot 2020-04-10 at 1 07 54 PM - Edited

@nielsmh
Copy link
Contributor

@nielsmh nielsmh commented Apr 10, 2020

Which video driver? SDL 1, SDL 2, or (unlikely) Allegro?

@CheeseSprinkles
Copy link
Author

@CheeseSprinkles CheeseSprinkles commented Apr 10, 2020

Which video driver? SDL 1, SDL 2, or (unlikely) Allegro?

SDL1, I think.

@CheeseSprinkles
Copy link
Author

@CheeseSprinkles CheeseSprinkles commented Apr 21, 2020

Playing in 1.10.1 now; problem still persists. Also, a savegame with the issue (which i forgot to attach originally)
test, Jan 1st, 2010.zip

@James103
Copy link
Contributor

@James103 James103 commented Jun 6, 2020

On Windows 10 Home 10.0.18363 Build 18363, moving the cursor a lot can cause the cursor to disappear (and/or be cut off) for a bit. Unfortunately, I was unable to capture that in a screenshot, but it happens in practice. It is better reproduced with an empty map.
openttd.cfg.zip

Configuration:
 Blitter:      32bpp-optimized
 Graphics set: OpenGFX (7393)
 Language:     C:\Program Files\OpenTTD\lang\english.lng
 Music driver: dmusic
 Music set:    Barry Taylor's Traditional American Tunebook Volume 2 (1)
 Network:      no
 Sound driver: xaudio2
 Sound set:    OpenSFX (87)
 Video driver: win32
@TrueBrain
Copy link
Member

@TrueBrain TrueBrain commented Feb 22, 2021

@James103 : upcoming nightly (that of 20210223) will have that fixed (see #8726).

@CheeseSprinkles : we did a lot of improvements on rendering in general, but I have never seen this issue in all the testing I did. Now there is a chance this is fixed in our latest nightly (https://www.openttd.org/downloads/openttd-nightlies/latest.html ). Would you mind giving that a spin to see if the problem is resolved?

Tnx!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants