Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Hotkeys don't work in non-english IME (such as Korean) #8138

Open
telk5093 opened this issue May 11, 2020 · 0 comments
Open

Hotkeys don't work in non-english IME (such as Korean) #8138

telk5093 opened this issue May 11, 2020 · 0 comments

Comments

@telk5093
Copy link
Contributor

@telk5093 telk5093 commented May 11, 2020

Version of OpenTTD

All versions, I think since 0.5.x

Expected result

Hotkey works

Actual result

Do not.

Steps to reproduce

Korean IME changes Korean and English input mode by pressing Kor/Eng button.
Kor/Eng button is displayed as 한/영 in the below keyboard image, which is at the left of RightAlt:
And note that is placed at A as you can see below:
Korean keyboard

In English input mode, as you know, pressing A turns on autorail construction mode. (GLOBAL+A)
However, Korean input mode, pressing has no any reactions.
Generally all hotkeys except for numbers do not work, from Q(ㅂ) to M(ㅡ).

I think the problem is hotkeys.cfg can't handle non-english.
This is the related old flyspray issue what I wrote a long ago:
https://bugs.openttd.org/task/6101

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant