Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Desktop file no longer installed #8613

Closed
ghisvail opened this issue Jan 27, 2021 · 5 comments · Fixed by #8834
Closed

Desktop file no longer installed #8613

ghisvail opened this issue Jan 27, 2021 · 5 comments · Fixed by #8834
Milestone

Comments

@ghisvail
Copy link
Contributor

@ghisvail ghisvail commented Jan 27, 2021

Version of OpenTTD

Version 1.11.0-beta1

Expected result

Version 1.10.3 used to install openttd.desktop under $PREFIX/share/applications. It is no longer the case for version 1.11.0-beta1, probably missing as a result of the change of build system. This is likely to break downstream packaging efforts expecting this file to be present, like Flatpak.

It should be enough to surround templated fields with @@ and call configure_file(..., @ONLY) on the current template.

@glx22
Copy link
Contributor

@glx22 glx22 commented Jan 27, 2021

Ah yes should be part of these TODOs

# TODO -- Media files
# TODO -- Menu files

@ghisvail
Copy link
Contributor Author

@ghisvail ghisvail commented Jan 27, 2021

I was able to fix it as a post-install step in the beta channel.

Thank you again for your recent pointers.

@ghisvail
Copy link
Contributor Author

@ghisvail ghisvail commented Jan 27, 2021

Apart for the missing media and desktop file integration, I expect the next stable release of the game should build fine downstream.

@TrueBrain
Copy link
Member

@TrueBrain TrueBrain commented Jan 27, 2021

As I don't really have another place to leave this information: you are currently parsing www.openttd.org to find the latest version. This is fine by me, but just so you know we also have this information in YAML format here: https://cdn.openttd.org/openttd-releases/latest.yaml ; might be useful :)

(similar we have those files for any other package we publish, like https://cdn.openttd.org/opengfx-releases/latest.yaml etc :))

@ghisvail
Copy link
Contributor Author

@ghisvail ghisvail commented Jan 27, 2021

@TrueBrain thanks, that's potentially very useful indeed. I'd have to check the capabilities of the Flathub parser first before considering a switch.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging a pull request may close this issue.

4 participants