Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Some screenshot buttons produce all-black screenshots #8774

Closed
2TallTyler opened this issue Mar 1, 2021 · 5 comments
Closed

Some screenshot buttons produce all-black screenshots #8774

2TallTyler opened this issue Mar 1, 2021 · 5 comments
Labels
bug component: OpenGL needs triage

Comments

@2TallTyler
Copy link
Member

@2TallTyler 2TallTyler commented Mar 1, 2021

Version of OpenTTD

1.11.0-beta2

Expected result

The screenshot button captures screenshots.

Actual result

Some of the screenshot buttons save a screenshot which is all black pixels:

  • Fully zoomed in screenshot
  • Default zoom screenshot
  • Whole map screenshot

The other buttons (Normal screenshot, Heightmap screenshot, and Minimap screenshot) all work as intended.

Steps to reproduce

Attempt to take a screenshot using the screenshot menu.

@perezdidac
Copy link
Contributor

@perezdidac perezdidac commented Mar 1, 2021

Taking a screenshot using the keyboard screen capture key on Windows 10 also produces a black image. I see the mouse though!

@James103
Copy link
Contributor

@James103 James103 commented Mar 1, 2021

Which video driver were you running? Can you try using other video drivers and/or blitters to see if that still reproduces the issue? It could be that some of the screenshots being blank are specific to certain video drivers and/or blitters.

@Eddi-z
Copy link
Contributor

@Eddi-z Eddi-z commented Mar 1, 2021

please note that those screenshot types can be much larger than your screen, and areas that are not on the map are filled in black. try zooming or scrolling and check that there are really no non-black areas in the screenshot file

also some image viewers may have problems with large files

@TrueBrain
Copy link
Member

@TrueBrain TrueBrain commented Mar 1, 2021

Confirmed. OpenGL only. Needs triage :)

@TrueBrain TrueBrain added bug needs triage component: OpenGL labels Mar 1, 2021
@TrueBrain
Copy link
Member

@TrueBrain TrueBrain commented Mar 1, 2021

More specific, it is the 40bpp-anim blitter.

michicc added a commit to michicc/OpenTTD that referenced this issue Mar 1, 2021
This affected all screenshot types that render to an off-screen
buffer and don't copy the actual screen contents.
@michicc michicc closed this as completed in 937d60f Mar 2, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug component: OpenGL needs triage
Projects
None yet
Development

No branches or pull requests

5 participants