Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

No "ERROR: " prefix in error message for "content select all" #8798

Closed
James103 opened this issue Mar 2, 2021 · 0 comments · Fixed by #8804
Closed

No "ERROR: " prefix in error message for "content select all" #8798

James103 opened this issue Mar 2, 2021 · 0 comments · Fixed by #8804
Labels
bug good first issue
Milestone

Comments

@James103
Copy link
Contributor

@James103 James103 commented Mar 2, 2021

Version of OpenTTD

1.11.0-beta2

Expected result

The output of "content select all" should be "ERROR: 'select all' is no longer supported since 1.11."

In other words, line 1837 here

IConsolePrintF(CC_ERROR, "'select all' is no longer supported since 1.11");

should instead be either of the following:

IConsoleError("'select all' is no longer supported since 1.11");

or (in case the IConsoleError method can't be used here)

IConsolePrintF(CC_ERROR, "ERROR: 'select all' is no longer supported since 1.11");

Actual result

image
(Notice there's no "ERROR: " prefix next to the error message)

Steps to reproduce

Run the following console commands while in the title screen:

content select all
kick
@TrueBrain TrueBrain added this to the 1.11.0 milestone Mar 3, 2021
@TrueBrain TrueBrain added bug good first issue labels Mar 3, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug good first issue
Projects
None yet
Development

Successfully merging a pull request may close this issue.

2 participants