Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Bug]: set signals from another railroad system #9509

Closed
HelmiMUC opened this issue Aug 23, 2021 · 4 comments
Closed

[Bug]: set signals from another railroad system #9509

HelmiMUC opened this issue Aug 23, 2021 · 4 comments

Comments

@HelmiMUC
Copy link

@HelmiMUC HelmiMUC commented Aug 23, 2021

Version of OpenTTD

1.12.0-beta2

Expected result

To set signals only for the selected railroad track system.

For example:
to set signals for Maglev railroad system on Maglev railroad tracks.

Actual result

At the moment it is possible to set signals from each system to any railroad tracks.
It doesn´t depend on the railroad system.

Steps to reproduce

For expample:

  1. set tracks from monorail railroad (or other railroad system)
  2. activate the Maglev constraction window (or other railroad system but not the same of #1)
  3. activate the signal build button
  4. set signal on the track
@TrueBrain
Copy link
Member

@TrueBrain TrueBrain commented Aug 23, 2021

Just thinking out loud: is this really a bug, or a feature? (honest question, to be clear)

Loading

@HelmiMUC
Copy link
Author

@HelmiMUC HelmiMUC commented Aug 23, 2021

It also the same with "waypoints".

So it seems, only constructions which contains a track have to be from the same railroad system (e. g. bridges, depot,...).
But constructions which will be added on the tracks (signals, waypoints) can be added from another railroad system.

Loading

@embeddedt
Copy link
Contributor

@embeddedt embeddedt commented Aug 23, 2021

I'd rather consider this a feature. It would be annoying to have to switch between types just to add/remove a signal.

Loading

@TrueBrain
Copy link
Member

@TrueBrain TrueBrain commented Aug 29, 2021

After some toying with this, and for the fact this has been this way for 17 years now, I think I am going to rule this "working as intended".

I can understand it might feel strange that you can put "maglev signals" on monorail, but making signals bind to their track-type, makes for very frustrating gameplay too. And I do not think there is anything inherently wrong by allowing it, other than surprising a few people from time to time.

So in the larger picture, I think it is better to allow this, and consider it a feature, than anything else. Sorry, but tnx for the report, it is much appreciated!

Loading

@TrueBrain TrueBrain closed this Aug 29, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants