Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Bug]: "ship is lost" is only reported via news #9523

Closed
TrueBrain opened this issue Aug 29, 2021 · 2 comments
Closed

[Bug]: "ship is lost" is only reported via news #9523

TrueBrain opened this issue Aug 29, 2021 · 2 comments

Comments

@TrueBrain
Copy link
Member

@TrueBrain TrueBrain commented Aug 29, 2021

Version of OpenTTD

12.0-beta2

Expected result

See somewhere on the vehicle or wherever, that the ship is lost.

Actual result

If a ship cannot reach its destination, it shows news about that once. This is true for all vehicles, but for ships even more annoying as they tend to drift towards the destination.

If you think you fixed the route, it doesn't update you with "route found!", so you are in the false sense you fixed the issue, and it never shows "ship is lost" again. This makes using ships a very frustrating experience.

Steps to reproduce

  1. Build a dock upstream
  2. Don't build a lock
  3. Build a depot downstream
  4. Build a ship
  5. Make it go to the dock
  6. Observe the news message about it being lost
  7. Try to find back whether it is still lost after that

What makes this extra annoying:
8. Build a lock, but the ship still cannot reach the dock
9. You will NOT receive any notification it still cannot reach the destination

@TrueBrain
Copy link
Member Author

@TrueBrain TrueBrain commented Aug 29, 2021

The biggest "well that is a shame" part, is that there is a flag to indicate the ship is lost in the vehicle flags (VF_PATHFINDER_LOST). It is just not used anywhere in the GUI.

It seems this is a pretty easy thing to address, we just need to find a clean way to present it to the user. Maybe in the status bar of the vehicle? Couldn't find a route to ... instead of Heading to ...?

@James103
Copy link
Contributor

@James103 James103 commented Aug 30, 2021

There could also be an alert symbol displayed in front of the vehicle's consist in the GUI. For example, if the VF_PATHFINDER_LOST flag is set, the alert symbol is shown, in order to further inform players in the vehicle listings.

SamuXarick added a commit to SamuXarick/OpenTTD that referenced this issue Sep 5, 2021
…cle window indicating whether a vehicle is lost
SamuXarick added a commit to SamuXarick/OpenTTD that referenced this issue Sep 7, 2021
…cle window indicating whether a vehicle is lost
@TrueBrain TrueBrain closed this Sep 14, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants