Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Bug]: Signal Lights logic problem #9554

Open
mwkaicz opened this issue Sep 14, 2021 · 2 comments
Open

[Bug]: Signal Lights logic problem #9554

mwkaicz opened this issue Sep 14, 2021 · 2 comments

Comments

@mwkaicz
Copy link

@mwkaicz mwkaicz commented Sep 14, 2021

Version of OpenTTD

12.0-beta2

Expected result

Bottom train should go to an empty slot in station.

Actual result

Signal light is blocking way without reason.
obrazek
obrazek
Train starts moving only when I remove rails to all used station slots. This bug appears randomly without any reason.

edit: added 2nd image

edit2: not even additional singal lights can fix it ... again: the train can't go through to the station:
obrazek

Steps to reproduce

Not sure. I have this schematic on many places but only here is the problem.

@glx22
Copy link
Contributor

@glx22 glx22 commented Sep 14, 2021

The 4 upper station tracks are too short for the train to fit, but I'm not sure it's the issue.

@mwkaicz
Copy link
Author

@mwkaicz mwkaicz commented Sep 14, 2021

I got this conclusion now too. But i think that it should still be able to use shorten slot. When it can use it without signal lights, why not with them?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants