Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Scheduled monthly dependency update for August #30

Merged
merged 1 commit into from Aug 1, 2021

Conversation

@pyup-bot
Copy link
Collaborator

@pyup-bot pyup-bot commented Aug 1, 2021

Update idna from 2.10 to 3.2.

Changelog

3.2

++++++++++++++++

- Add type hints (Thanks, Seth Michael Larson!)
- Remove support for Python 3.4

3.1

++++++++++++++++

- Ensure license is included in package (Thanks, Julien Schueller)
- No longer mark wheel has universal (Thanks, Matthieu Darbois)
- Test on PowerPC using Travis CI

3.0

++++++++++++++++

- Python 2 is no longer supported (the 2.x branch supports Python 2,
use "idna<3" in your requirements file if you need Python 2 support)
- Support for V2 UTS 46 test vectors.
Links

Update requests from 2.25.1 to 2.26.0.

Changelog

2.26.0

-------------------

**Improvements**

- Requests now supports Brotli compression, if either the `brotli` or
`brotlicffi` package is installed. (5783)

- `Session.send` now correctly resolves proxy configurations from both
the Session and Request. Behavior now matches `Session.request`. (5681)

**Bugfixes**

- Fixed a race condition in zip extraction when using Requests in parallel
from zip archive. (5707)

**Dependencies**

- Instead of `chardet`, use the MIT-licensed `charset_normalizer` for Python3
to remove license ambiguity for projects bundling requests. If `chardet`
is already installed on your machine it will be used instead of `charset_normalizer`
to keep backwards compatibility. (5797)

You can also install `chardet` while installing requests by
specifying `[use_chardet_on_py3]` extra as follows:

 shell
 pip install "requests[use_chardet_on_py3]"
 

Python2 still depends upon the `chardet` module.

- Requests now supports `idna` 3.x on Python 3. `idna` 2.x will continue to
be used on Python 2 installations. (5711)

**Deprecations**

- The `requests[security]` extra has been converted to a no-op install.
PyOpenSSL is no longer the recommended secure option for Requests. (5867)

- Requests has officially dropped support for Python 3.5. (5867)
Links

Update tinydb from 4.5.0 to 4.5.1.

Changelog

4.5.1

^^^^^^^^^^^^^^^^^^^

- Fix: Correctly install ``typing-extensions`` on Python 3.7
(see `issue 413 <https://github.com/msiemens/tinydb/issues/413>`__)
Links
@TrueBrain TrueBrain force-pushed the pyup-scheduled-update-2021-08-01 branch from 5b59ab8 to 015cb19 Aug 1, 2021
* Update idna from 2.10 to 3.2
* Update requests from 2.25.1 to 2.26.0
* Update tinydb from 4.5.0 to 4.5.1
@TrueBrain TrueBrain force-pushed the pyup-scheduled-update-2021-08-01 branch from 015cb19 to 0e11eb2 Aug 1, 2021
@TrueBrain TrueBrain merged commit 07d25e0 into main Aug 1, 2021
6 checks passed
Loading
@TrueBrain TrueBrain deleted the pyup-scheduled-update-2021-08-01 branch Aug 1, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants