Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Development version format is "invalid" to setuptools. #100

Closed
FLHerne opened this issue Apr 22, 2020 · 0 comments
Closed

Development version format is "invalid" to setuptools. #100

FLHerne opened this issue Apr 22, 2020 · 0 comments

Comments

@FLHerne
Copy link
Contributor

@FLHerne FLHerne commented Apr 22, 2020

When running setup.py I get the following warning:

/usr/lib/python3.8/site-packages/setuptools/dist.py:468: UserWarning: The version specified ('2020-04-20-g9fdd4bbc') is an invalid version, this may not work as expected with newer versions of setuptools, pip, and PyPI. Please see PEP 440 for more details.

Link to PEP 440.

It looks like the preferred version format would be something like 0.4.5.post87+g9fdd4bbc

glx22 added a commit to glx22/nml that referenced this issue Apr 23, 2020
@glx22 glx22 closed this in 7cbd236 Apr 28, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.