New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Okapi update #731

Closed
wants to merge 1 commit into
base: development
from

Conversation

Projects
None yet
2 participants
@following5
Copy link
Contributor

following5 commented Dec 17, 2018

see changelog

bugfix v1873 requested by mic@

@teiling88

This comment has been minimized.

Copy link
Member

teiling88 commented Dec 17, 2018

Ich weiß das Du nichts für aktuelle Technologien wie z.B. Composer übrig hast aber ein okapi Update läuft nun einmal darüber. Der Content-Hash fehlt in deiner manuell angepassten composer.lock siehe 9648221

Entweder führst Du ./psh.phar update-okapi-package aus oder führst die beiden Befehle aus dieser Datei aus.

Das Du die Unit-Tests die dadurch fehlschlagen anpassen sollst verlange ich ja noch nicht einmal von dir.

@teiling88 teiling88 closed this Dec 17, 2018

@following5

This comment has been minimized.

Copy link
Contributor

following5 commented Dec 17, 2018

Ich weiß das Du nichts für aktuelle Technologien wie z.B. Composer übrig hast aber ein okapi Update läuft nun einmal darüber. Der Content-Hash fehlt in deiner manuell angepassten composer.lock siehe e8430e9.

@following5

This comment has been minimized.

Copy link
Contributor

following5 commented Dec 17, 2018

Mein letzter Versuch, deine buggy Okapi-Unit-Tests zu korrigieren (#668), wurde von dir abgewiesen, also lass das bitte mal stecken.

@teiling88

This comment has been minimized.

Copy link
Member

teiling88 commented Dec 17, 2018

Peter das hat nichts mit Buggy zu tun. Wenn sich die eingesetzte Software ändert müssen Tests fehl schlagen sonst waren sie nicht gut.

Es gibt dafür sogar Testmöglichkeiten die die Tests genau auf dieses Verhalten prüfen. Nennt sich Mutation Testing.

@following5

This comment has been minimized.

Copy link
Contributor

following5 commented Dec 17, 2018

Wenn sich die eingesetzte Software ändert müssen Tests fehl schlagen

Nur wenn die Änderung nicht abwärtskompatibel ist, andernfalls ist der Test fehlerhaft.

@OpencachingDeutschland OpencachingDeutschland locked as too heated and limited conversation to collaborators Dec 18, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.