New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Invalid response to Association query #25

Open
georgooty opened this Issue Dec 23, 2013 · 1 comment

Comments

Projects
None yet
2 participants
@georgooty

georgooty commented Dec 23, 2013

Hi,

The WS-Management CIM Binding Spec R8.2-1 says, the Assocation query (request with association filter) should be addressed to the "all classes" resource URI. When I send a enumerate request addressed to the CIM_ComputerSystem with the association filter query, I am getting back a EnumerateResponse (with context which fetches the CIM_ComputerSystem with a further Pull request). The spec says the service should return a "wsen:FilterDialectRequestedUnavailable" fault.

If filter dialects is not supported at all with Enumerate, it should return a wsen:FilteringNotSupported fault.

soap request is given below,

https://gist.github.com/georgooty/9eb26dfdcf4385ed7a85

@kkaempf

This comment has been minimized.

Show comment
Hide comment
@kkaempf

kkaempf Mar 24, 2014

Collaborator

I agree that Openwsman doesn't act according to the standard here.

However, I am a bit reluctant to change it in the 2.4.x branch since there might be applications in the wild making use of this bug.

Collaborator

kkaempf commented Mar 24, 2014

I agree that Openwsman doesn't act according to the standard here.

However, I am a bit reluctant to change it in the 2.4.x branch since there might be applications in the wild making use of this bug.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment