Stripe Ruby bindings
Ruby
Pull request Compare This branch is 279 commits behind stripe:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
bin
gemfiles
lib
test
.gitignore
.travis.yml
CONTRIBUTORS
Gemfile
History.txt
LICENSE
README.rdoc
Rakefile
VERSION
stripe.gemspec

README.rdoc

Stripe Ruby bindings Build Status

Documentation

Ruby API Docs

Installation

You don't need this source code unless you want to modify the gem. If you just want to use the Stripe Ruby bindings, you should run:

gem install stripe

If you want to build the gem from source:

gem build stripe.gemspec

Requirements

  • Ruby 1.8.7 or above. (Ruby 1.8.6 may work if you load ActiveSupport.) For Ruby versions before 1.9.2, you'll need to add this to your Gemfile:

    if Gem::Version.new(RUBY_VERSION) < Gem::Version.new('1.9.2')
      gem 'rest-client', '~> 1.6.8'
    end
  • rest-client, json

Bundler

If you are installing via bundler, you should be sure to use the https rubygems source in your Gemfile, as any gems fetched over http could potentially be compromised in transit and alter the code of gems fetched securely over https:

source 'https://rubygems.org'

gem 'rails'
gem 'stripe'

Development

Test cases can be run with: `bundle exec rake test`