Cannot find generator #8

Open
jchheng opened this Issue Nov 10, 2010 · 9 comments

5 participants

@jchheng

First, thanks for taking over this project. We've been using it for about year. We're just updating to Rails 3.0.1 and trying to install 0.4.1 of apn_on_rails, everything seems to work but can't run the migration using this: rails g apn_migrations

Is this a known issue or is it me?

@chrisrhoden
Public Radio Exchange member

The current version of the gem is not Rails 3 compatible. We are planning it for one of the next 2 releases.

@xhan

hope it comes soon.
thnaks for all the works.

@twigbranch

We also need to figure this out ASAP.

@twigbranch

is the issue with rails 3 only the generators or are there other significant changes required?

@chrisrhoden
Public Radio Exchange member

As far as I can tell, the generators are the big hangup at this point. There may be other incompatibilities, but testing isn't something we can do until we sit down and write new generators. And, I should say I don't expect there to be any other major incompatibilities.

@twigbranch

saw a couple of forks which seems to at Rails 3 compatibility. don't suppose you've seen those?

@chrisrhoden
Public Radio Exchange member

We haven't received any pull requests.

I suspect that these break compatibility with Rails 2, which is vital for us. I will take a look at what those are. If you have created a patch or know someone who has, please have them submit a pull request with tests.

@twigbranch

I'm trying the one by pg13. the generators work - don't know about rails 2

@andmej

I'm struggling with this too. How can I contribute?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment