Skip to content

A lightweight Clojurescript wrapper around Blockly

License

Notifications You must be signed in to change notification settings

ParkerICI/blockoid

Folders and files

NameName
Last commit message
Last commit date

Latest commit

 

History

30 Commits
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Repository files navigation

blockoid

A thin Clojurescript wrapping of Blockly, a library for building Scratch-like interfaces in the browser.

The combination of Blockly and Clojure allows for the easy creation of powerful combinatorial user interfaces and visual languages. See this presentation for a real-world example of use.

screenshot

Usage

Add to dependencies:

[org.parkerici/blockoid "0.3.5"] 

See the example for details.

In your code, add the require:

(ns ...
  (:require [org.parkerici.blockoid.core :as blockoid]))

Usage details are in (a separate document)[doc/blockoid.md].

Blockoid loads Blockly via a cljsjs package. If you need a newer version of Blockly, you will need to update cljsjs.

License

Relased under MIT license. See the LICENSE file for details.

About

A lightweight Clojurescript wrapper around Blockly

Resources

License

Stars

Watchers

Forks

Releases

No releases published

Packages