New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Parsl version conflict with libsubmit 0.4.1 #347

Closed
yadudoc opened this Issue Jun 21, 2018 · 1 comment

Comments

Projects
None yet
1 participant
@yadudoc
Contributor

yadudoc commented Jun 21, 2018

Libsubmit 0.4.1 makes several changes to the provider interfaces that will not work with Parsl v0.5.1 and earlier. All Parsl versions released till now specify libsubmit>=XX>YY>ZZ as a requirement, meaning if the user explicitly updates libsubmit, they could end with incompatible versions. This means that until the next release is made, users making fresh parsl installs will be faced with incompatible parsl and libsubmit versions.

I'm working on a quick 0.5.2 point release as a stop gap.

@yadudoc yadudoc added the bug label Jun 21, 2018

@yadudoc yadudoc self-assigned this Jun 21, 2018

@yadudoc

This comment has been minimized.

Contributor

yadudoc commented Jun 21, 2018

I've made a release from branch: https://github.com/Parsl/parsl/tree/emergeny_release_%23347
which is forked from master where the 0.5.1 tag was made.

@yadudoc yadudoc closed this Jun 21, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment