New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Scripts don't declare RL module dependencies #89

Closed
hartman opened this Issue Apr 30, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@hartman

hartman commented Apr 30, 2017

Hi, this script is not declaring/enforcing it's dependency on mediawiki.util. This likely causes JS errors for users of this script, as Paine Ellsworth, who has this installed in global.js

See also report:
https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)#Edit_screen_instability

@Pathoschild Pathoschild self-assigned this May 1, 2017

@Pathoschild Pathoschild added the bug label May 1, 2017

@Pathoschild Pathoschild changed the title from TemplateScript does not declare dependency on mediawiki.util RL module to Scripts don't declare RL module dependencies May 1, 2017

@Pathoschild

This comment has been minimized.

Show comment
Hide comment
@Pathoschild

Pathoschild May 1, 2017

Owner

Fixed in c4c70ea and deployed. You may need to clear your cache to see the changes. Let me know whether you still have any issues. :)

Owner

Pathoschild commented May 1, 2017

Fixed in c4c70ea and deployed. You may need to clear your cache to see the changes. Let me know whether you still have any issues. :)

@Pathoschild Pathoschild closed this May 1, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment