Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Compress::Zlib location conflicts with autosplit #10282

Closed
p5pRT opened this issue Apr 6, 2010 · 14 comments
Closed

Compress::Zlib location conflicts with autosplit #10282

p5pRT opened this issue Apr 6, 2010 · 14 comments

Comments

@p5pRT
Copy link

@p5pRT p5pRT commented Apr 6, 2010

Migrated from rt.perl.org#74088 (status was 'resolved')

Searchable as RT74088$

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 6, 2010

From mls@suse.de

Created by mls@suse.de

The following code (stripped down from Mail-SpamAssassin-3.3.1) prints
an error under 5.12.0​:

  $SIG{'__DIE__'} = sub { print("error @​_") unless $^S; };
  require Compress​::Zlib;

The difference between 5.10.1 and 5.12.0 is a change in the location of
Compress​::Zlib. It used to live in archlib, but now is in privlib. The
autosplit files like autosplit.ix get installed into archlib nevertheless.

(It's also weird that $^S is not set in the __DIE__ handler, but 5.10.1
also shows this behaviour.)

Perl Info

Flags:
    category=core
    severity=medium

This perlbug was built using Perl 5.12.0 - Tue Apr  6 13:36:06 UTC 2010
It is being executed now by  Perl 5.12.0 - Tue Apr  6 13:29:13 UTC 2010.

Site configuration information for perl 5.12.0:

Configured by abuild at Tue Apr  6 13:29:13 UTC 2010.

Summary of my perl5 (revision 5 version 12 subversion 0) configuration:
   
  Platform:
    osname=linux, osvers=2.6.32, archname=i586-linux-thread-multi
    uname='linux build33 2.6.32 #1 smp 2010-01-06 16:07:25 +0100 i686 athlon i386 gnulinux '
    config_args='-ds -e -Dprefix=/usr -Dvendorprefix=/usr -Dinstallusrbinperl -Dusethreads -Di_db -Di_dbm -Di_ndbm -Di_gdbm -Duseshrplib=true -Doptimize=-fomit-frame-pointer -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -Wall -pipe -Accflags=-DPERL_USE_SAFE_PUTENV'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=undef, use64bitall=undef, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -DPERL_USE_SAFE_PUTENV -fno-strict-aliasing -pipe -fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-fomit-frame-pointer -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -Wall -pipe',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -DPERL_USE_SAFE_PUTENV -fno-strict-aliasing -pipe -fstack-protector'
    ccversion='', gccversion='4.5.0 20100331 (experimental) [trunk revision 157870]', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector'
    libpth=/lib /usr/lib /usr/local/lib
    libs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    libc=/lib/libc-2.11.1.so, so=so, useshrplib=true, libperl=libperl.so
    gnulibc_version='2.11.1'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E -Wl,-rpath,/usr/lib/perl5/5.12.0/i586-linux-thread-multi/CORE'
    cccdlflags='-fPIC', lddlflags='-shared -fomit-frame-pointer -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -Wall -pipe'

Locally applied patches:
    RC1


@INC for perl 5.12.0:
    /usr/lib/perl5/site_perl/5.12.0/i586-linux-thread-multi
    /usr/lib/perl5/site_perl/5.12.0
    /usr/lib/perl5/vendor_perl/5.12.0/i586-linux-thread-multi
    /usr/lib/perl5/vendor_perl/5.12.0
    /usr/lib/perl5/5.12.0/i586-linux-thread-multi
    /usr/lib/perl5/5.12.0
    .


Environment for perl 5.12.0:
    HOME=/root
    LANG (unset)
    LANGUAGE (unset)
    LC_COLLATE=POSIX
    LC_CTYPE=de_DE@euro
    LD_LIBRARY_PATH (unset)
    LOGDIR (unset)
    PATH=/suse/mls/bin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin:/usr/X11R6/bin:/bin:/usr/lib/java/bin:/usr/games/bin:/usr/games:/opt/gnome/bin:/opt/kde/bin:/usr/openwin/bin:/opt/pilotsdk/bin:/suse/mls/korn
    PERL_BADLANG (unset)
    SHELL=/bin/bash

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 8, 2010

From @pmqs

Is the change below, that was made a while back when Compress​::Zlib lost it's xs file, responsible for the issue?

  (
  $] >= 5.009 && $] <= 5.011001 && ! $ENV{PERL_CORE}
  ? (INSTALLPRIVLIB => '$(INSTALLARCHLIB)')
  : ()
  ),

If so, does it need to change?

Paul

-----Original Message-----
From​: via RT [mailto​:mls@​suse.deperlbug-followup@​perl.org]
Sent​: 06 April 2010 17​:33
To​: bugs-bitbucket@​rt.perl.org
Subject​: [perl #74088] Compress​::Zlib location conflicts with autosplit

# New Ticket Created by mls@​suse.de
# Please include the string​: [perl #74088]
# in the subject line of all future correspondence about this issue.
# <URL​: http​://rt.perl.org/rt3/Ticket/Display.html?id=74088 >

This is a bug report for perl from mls@​suse.de,
generated with the help of perlbug 1.39 running under perl 5.12.0.

-----------------------------------------------------------------
[Please describe your issue here]

The following code (stripped down from Mail-SpamAssassin-3.3.1) prints
an error under 5.12.0​:

$SIG\{'\_\_DIE\_\_'\} = sub \{ print\("error @&#8203;\_"\) unless $^S; \};
require Compress&#8203;::Zlib;

The difference between 5.10.1 and 5.12.0 is a change in the location of
Compress​::Zlib. It used to live in archlib, but now is in privlib. The
autosplit files like autosplit.ix get installed into archlib
nevertheless.

(It's also weird that $^S is not set in the __DIE__ handler, but 5.10.1
also shows this behaviour.)

[Please do not change anything below this line]
-----------------------------------------------------------------
---
Flags​:
category=core
severity=medium
---
This perlbug was built using Perl 5.12.0 - Tue Apr 6 13​:36​:06 UTC 2010
It is being executed now by Perl 5.12.0 - Tue Apr 6 13​:29​:13 UTC
2010.

Site configuration information for perl 5.12.0​:

Configured by abuild at Tue Apr 6 13​:29​:13 UTC 2010.

Summary of my perl5 (revision 5 version 12 subversion 0) configuration​:

Platform​:
osname=linux, osvers=2.6.32, archname=i586-linux-thread-multi
uname='linux build33 2.6.32 #1 smp 2010-01-06 16​:07​:25 +0100 i686
athlon i386 gnulinux '
config_args='-ds -e -Dprefix=/usr -Dvendorprefix=/usr -
Dinstallusrbinperl -Dusethreads -Di_db -Di_dbm -Di_ndbm -Di_gdbm -
Duseshrplib=true -Doptimize=-fomit-frame-pointer -fmessage-length=0 -O2
-Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -
fasynchronous-unwind-tables -Wall -pipe -Accflags=-
DPERL_USE_SAFE_PUTENV'
hint=recommended, useposix=true, d_sigaction=define
useithreads=define, usemultiplicity=define
useperlio=define, d_sfio=undef, uselargefiles=define,
usesocks=undef
use64bitint=undef, use64bitall=undef, uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler​:
cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -
DPERL_USE_SAFE_PUTENV -fno-strict-aliasing -pipe -fstack-protector -
D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
optimize='-fomit-frame-pointer -fmessage-length=0 -O2 -Wall -
D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-
unwind-tables -Wall -pipe',
cppflags='-D_REENTRANT -D_GNU_SOURCE -DPERL_USE_SAFE_PUTENV -fno-
strict-aliasing -pipe -fstack-protector'
ccversion='', gccversion='4.5.0 20100331 (experimental) [trunk
revision 157870]', gccosandvers=''
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t',
lseeksize=8
alignbytes=4, prototype=define
Linker and Libraries​:
ld='cc', ldflags =' -fstack-protector'
libpth=/lib /usr/lib /usr/local/lib
libs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
libc=/lib/libc-2.11.1.so, so=so, useshrplib=true,
libperl=libperl.so
gnulibc_version='2.11.1'
Dynamic Linking​:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E -
Wl,-rpath,/usr/lib/perl5/5.12.0/i586-linux-thread-multi/CORE'
cccdlflags='-fPIC', lddlflags='-shared -fomit-frame-pointer -
fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -
funwind-tables -fasynchronous-unwind-tables -Wall -pipe'

Locally applied patches​:
RC1

---
@​INC for perl 5.12.0​:
/usr/lib/perl5/site_perl/5.12.0/i586-linux-thread-multi
/usr/lib/perl5/site_perl/5.12.0
/usr/lib/perl5/vendor_perl/5.12.0/i586-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.12.0
/usr/lib/perl5/5.12.0/i586-linux-thread-multi
/usr/lib/perl5/5.12.0
.

---
Environment for perl 5.12.0​:
HOME=/root
LANG (unset)
LANGUAGE (unset)
LC_COLLATE=POSIX
LC_CTYPE=de_DE@​euro
LD_LIBRARY_PATH (unset)
LOGDIR (unset)

PATH=/suse/mls/bin​:/usr/local/bin​:/usr/bin​:/usr/sbin​:/sbin​:/usr/X11R6/b
in​:/bin​:/usr/lib/java/bin​:/usr/games/bin​:/usr/games​:/opt/gnome/bin​:/opt
/kde/bin​:/usr/openwin/bin​:/opt/pilotsdk/bin​:/suse/mls/korn
PERL_BADLANG (unset)
SHELL=/bin/bash

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 8, 2010

The RT System itself - Status changed from 'new' to 'open'

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 9, 2010

From mls@suse.de

A simple fix would be to add 'Compress/Zlib' to the archpms
hash in installperl.

M.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 9, 2010

From @pmqs

I've found the problem.

Compress​::Zlib still has an autoload section that was needed when it was an XS module. I forgot to remove it when the XS code got moved to Compress​::Raw​::Zlib.

I'll sort out the CPAN copy.

Paul

-----Original Message-----
From​: via RT [mailto​:mls@​suse.deperlbug-followup@​perl.org]
Sent​: 06 April 2010 17​:33
To​: bugs-bitbucket@​rt.perl.org
Subject​: [perl #74088] Compress​::Zlib location conflicts with autosplit

# New Ticket Created by mls@​suse.de
# Please include the string​: [perl #74088]
# in the subject line of all future correspondence about this issue.
# <URL​: http​://rt.perl.org/rt3/Ticket/Display.html?id=74088 >

This is a bug report for perl from mls@​suse.de,
generated with the help of perlbug 1.39 running under perl 5.12.0.

-----------------------------------------------------------------
[Please describe your issue here]

The following code (stripped down from Mail-SpamAssassin-3.3.1) prints
an error under 5.12.0​:

$SIG\{'\_\_DIE\_\_'\} = sub \{ print\("error @&#8203;\_"\) unless $^S; \};
require Compress&#8203;::Zlib;

The difference between 5.10.1 and 5.12.0 is a change in the location of
Compress​::Zlib. It used to live in archlib, but now is in privlib. The
autosplit files like autosplit.ix get installed into archlib
nevertheless.

(It's also weird that $^S is not set in the __DIE__ handler, but 5.10.1
also shows this behaviour.)

[Please do not change anything below this line]
-----------------------------------------------------------------
---
Flags​:
category=core
severity=medium
---
This perlbug was built using Perl 5.12.0 - Tue Apr 6 13​:36​:06 UTC 2010
It is being executed now by Perl 5.12.0 - Tue Apr 6 13​:29​:13 UTC
2010.

Site configuration information for perl 5.12.0​:

Configured by abuild at Tue Apr 6 13​:29​:13 UTC 2010.

Summary of my perl5 (revision 5 version 12 subversion 0) configuration​:

Platform​:
osname=linux, osvers=2.6.32, archname=i586-linux-thread-multi
uname='linux build33 2.6.32 #1 smp 2010-01-06 16​:07​:25 +0100 i686
athlon i386 gnulinux '
config_args='-ds -e -Dprefix=/usr -Dvendorprefix=/usr -
Dinstallusrbinperl -Dusethreads -Di_db -Di_dbm -Di_ndbm -Di_gdbm -
Duseshrplib=true -Doptimize=-fomit-frame-pointer -fmessage-length=0 -O2
-Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -
fasynchronous-unwind-tables -Wall -pipe -Accflags=-
DPERL_USE_SAFE_PUTENV'
hint=recommended, useposix=true, d_sigaction=define
useithreads=define, usemultiplicity=define
useperlio=define, d_sfio=undef, uselargefiles=define,
usesocks=undef
use64bitint=undef, use64bitall=undef, uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler​:
cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -
DPERL_USE_SAFE_PUTENV -fno-strict-aliasing -pipe -fstack-protector -
D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
optimize='-fomit-frame-pointer -fmessage-length=0 -O2 -Wall -
D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-
unwind-tables -Wall -pipe',
cppflags='-D_REENTRANT -D_GNU_SOURCE -DPERL_USE_SAFE_PUTENV -fno-
strict-aliasing -pipe -fstack-protector'
ccversion='', gccversion='4.5.0 20100331 (experimental) [trunk
revision 157870]', gccosandvers=''
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t',
lseeksize=8
alignbytes=4, prototype=define
Linker and Libraries​:
ld='cc', ldflags =' -fstack-protector'
libpth=/lib /usr/lib /usr/local/lib
libs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
libc=/lib/libc-2.11.1.so, so=so, useshrplib=true,
libperl=libperl.so
gnulibc_version='2.11.1'
Dynamic Linking​:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E -
Wl,-rpath,/usr/lib/perl5/5.12.0/i586-linux-thread-multi/CORE'
cccdlflags='-fPIC', lddlflags='-shared -fomit-frame-pointer -
fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -
funwind-tables -fasynchronous-unwind-tables -Wall -pipe'

Locally applied patches​:
RC1

---
@​INC for perl 5.12.0​:
/usr/lib/perl5/site_perl/5.12.0/i586-linux-thread-multi
/usr/lib/perl5/site_perl/5.12.0
/usr/lib/perl5/vendor_perl/5.12.0/i586-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.12.0
/usr/lib/perl5/5.12.0/i586-linux-thread-multi
/usr/lib/perl5/5.12.0
.

---
Environment for perl 5.12.0​:
HOME=/root
LANG (unset)
LANGUAGE (unset)
LC_COLLATE=POSIX
LC_CTYPE=de_DE@​euro
LD_LIBRARY_PATH (unset)
LOGDIR (unset)

PATH=/suse/mls/bin​:/usr/local/bin​:/usr/bin​:/usr/sbin​:/sbin​:/usr/X11R6/b
in​:/bin​:/usr/lib/java/bin​:/usr/games/bin​:/usr/games​:/opt/gnome/bin​:/opt
/kde/bin​:/usr/openwin/bin​:/opt/pilotsdk/bin​:/suse/mls/korn
PERL_BADLANG (unset)
SHELL=/bin/bash

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 9, 2010

From @pmqs

From​: Michael Schroeder [mailto​:mls@​suse.de]

A simple fix would be to add 'Compress/Zlib' to the archpms
hash in installperl.

Sorry, no - Compress​::Zlib isn't arch dependent anymore.

Paul

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 9, 2010

From @pmqs

From​: Michael Schroeder [mailto​:mls@​suse.de]

On Fri, Apr 09, 2010 at 05​:38​:07PM +0100, Paul Marquess wrote​:

From​: Michael Schroeder [mailto​:mls@​suse.de]

A simple fix would be to add 'Compress/Zlib' to the archpms
hash in installperl.

Sorry, no - Compress​::Zlib isn't arch dependent anymore.

Then please fix installperl so that Compress​::Zlib's autosplit.ix
file doesn't get installed into perlarch. Currently is assumes
everything in the 'auto' directory is arch dependent.

Yep, I have that sorted.

Paul

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 10, 2010

From mls@suse.de

On Fri, Apr 09, 2010 at 05​:38​:07PM +0100, Paul Marquess wrote​:

From​: Michael Schroeder [mailto​:mls@​suse.de]

A simple fix would be to add 'Compress/Zlib' to the archpms
hash in installperl.

Sorry, no - Compress​::Zlib isn't arch dependent anymore.

Then please fix installperl so that Compress​::Zlib's autosplit.ix
file doesn't get installed into perlarch. Currently is assumes
everything in the 'auto' directory is arch dependent.

Cheers,
  Michael.

--
Michael Schroeder mls@​suse.de
SUSE LINUX Products GmbH, GF Markus Rex, HRB 16746 AG Nuernberg
main(_){while(_=getchar())putchar(_-1/(~(_|32)/13*2-11)*13);}

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 12, 2010

From @iabyn

On Fri, Apr 09, 2010 at 11​:48​:05PM +0100, Paul Marquess wrote​:

From​: Michael Schroeder [mailto​:mls@​suse.de]

On Fri, Apr 09, 2010 at 05​:38​:07PM +0100, Paul Marquess wrote​:

From​: Michael Schroeder [mailto​:mls@​suse.de]

A simple fix would be to add 'Compress/Zlib' to the archpms
hash in installperl.

Sorry, no - Compress​::Zlib isn't arch dependent anymore.

Then please fix installperl so that Compress​::Zlib's autosplit.ix
file doesn't get installed into perlarch. Currently is assumes
everything in the 'auto' directory is arch dependent.

Yep, I have that sorted.

Is this something that will need pulling in for 5.12.1?

--
Lady Nancy Astor​: If you were my husband, I would flavour your coffee
with poison.
Churchill​: Madam - if I were your husband, I would drink it.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 12, 2010

From @pmqs

-----Original Message-----
From​: Dave Mitchell [mailto​:davem@​iabyn.com]
Sent​: 12 April 2010 17​:18
To​: Paul Marquess
Cc​: 'Michael Schroeder'; perl5-porters@​perl.org; perlbug-
followup@​perl.org
Subject​: Re​: [perl #74088] perlbug AutoReply​: Compress​::Zlib location
conflicts with autosplit

On Fri, Apr 09, 2010 at 11​:48​:05PM +0100, Paul Marquess wrote​:

From​: Michael Schroeder [mailto​:mls@​suse.de]

On Fri, Apr 09, 2010 at 05​:38​:07PM +0100, Paul Marquess wrote​:

From​: Michael Schroeder [mailto​:mls@​suse.de]

A simple fix would be to add 'Compress/Zlib' to the archpms
hash in installperl.

Sorry, no - Compress​::Zlib isn't arch dependent anymore.

Then please fix installperl so that Compress​::Zlib's autosplit.ix
file doesn't get installed into perlarch. Currently is assumes
everything in the 'auto' directory is arch dependent.

Yep, I have that sorted.

Is this something that will need pulling in for 5.12.1?

I'd say, yes, it is.

That can be achieved by either syncing core with the CPAN copy of
Compress​::Zlib (when I actually upload it), or just fixing this particular
issue. I suspect the latter if we follow Jesse's rules-of-engagement for
5.12.X

Paul

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 15, 2010

From @pmqs

Here is a patch that addresses #74088

I'll include this in the next CPAN update for Compress​::Zlib

Paul

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Apr 15, 2010

From @pmqs

0001-perl-74088.patch
From 571d8c96cf5d0683212052ceac7c8e53f40b3f3c Mon Sep 17 00:00:00 2001
From: paul <paul@paul-desktop.(none)>
Date: Thu, 15 Apr 2010 19:35:44 +0100
Subject: [PATCH] perl-74088

---
 cpan/IO-Compress/Changes              |    6 ++++++
 cpan/IO-Compress/lib/Compress/Zlib.pm |   15 ++-------------
 2 files changed, 8 insertions(+), 13 deletions(-)

diff --git a/cpan/IO-Compress/Changes b/cpan/IO-Compress/Changes
index c98bef1..e3a7a70 100644
--- a/cpan/IO-Compress/Changes
+++ b/cpan/IO-Compress/Changes
@@ -1,6 +1,12 @@
 CHANGES
 -------
 
+  2.024_01 15 April 2010
+
+      * Compress::Zlib
+        Remove autoload code from Zlib.pm.
+        [perl #74088]
+
   2.024 7 January 2010
 
       * Compress::Zlib
diff --git a/cpan/IO-Compress/lib/Compress/Zlib.pm b/cpan/IO-Compress/lib/Compress/Zlib.pm
index 9424df6..b546dac 100644
--- a/cpan/IO-Compress/lib/Compress/Zlib.pm
+++ b/cpan/IO-Compress/lib/Compress/Zlib.pm
@@ -3,7 +3,6 @@ package Compress::Zlib;
 
 require 5.004 ;
 require Exporter;
-use AutoLoader;
 use Carp ;
 use IO::Handle ;
 use Scalar::Util qw(dualvar);
@@ -16,9 +15,9 @@ use IO::Uncompress::Gunzip 2.024 ;
 use strict ;
 use warnings ;
 use bytes ;
-our ($VERSION, $XS_VERSION, @ISA, @EXPORT, @EXPORT_OK, %EXPORT_TAGS, $AUTOLOAD);
+our ($VERSION, $XS_VERSION, @ISA, @EXPORT, @EXPORT_OK, %EXPORT_TAGS);
 
-$VERSION = '2.024';
+$VERSION = '2.024_01';
 $XS_VERSION = $VERSION; 
 $VERSION = eval $VERSION;
 
@@ -46,16 +45,6 @@ BEGIN
     *zlib_version = \&Compress::Raw::Zlib::zlib_version;
 }
 
-sub AUTOLOAD {
-    my($constname);
-    ($constname = $AUTOLOAD) =~ s/.*:://;
-    my ($error, $val) = Compress::Raw::Zlib::constant($constname);
-    Carp::croak $error if $error;
-    no strict 'refs';
-    *{$AUTOLOAD} = sub { $val };
-    goto &{$AUTOLOAD};
-}
-
 use constant FLAG_APPEND             => 1 ;
 use constant FLAG_CRC                => 2 ;
 use constant FLAG_ADLER              => 4 ;
-- 
1.6.0.4

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 14, 2011

From @cpansprout

This was fixed by commit e8796d6.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 14, 2011

@cpansprout - Status changed from 'open' to 'resolved'

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant