Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ISA warnings after aliasing packages #10562

Closed
p5pRT opened this issue Aug 22, 2010 · 4 comments
Closed

ISA warnings after aliasing packages #10562

p5pRT opened this issue Aug 22, 2010 · 4 comments

Comments

@p5pRT
Copy link
Collaborator

@p5pRT p5pRT commented Aug 22, 2010

Migrated from rt.perl.org#77358 (status was 'resolved')

Searchable as RT77358$

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Aug 22, 2010

From @cpansprout

This little script (part of a test I’m preparing for part of bug #75176)—

use warnings;
{
@​Pet​::ISA = "Tike";
@​Tike​::ISA = "Barker";

sub Barker​::speak { "Woof!" }
sub Latrator​::speak { "Bow-wow!" }

my $pet = bless [], "Pet";

@​Dog​::ISA = 'Latrator';
my $tike_glob = delete $​::{'Tike​::'};
$​::{'Tike​::'} = delete $​::{'Dog​::'};

$pet->speak;

undef $tike_glob;
$pet->speak;
}

—produces these warnings, as of perl 5.10.0​:

Can't locate package Dog for @​Pet​::ISA at - line 18.
Can't locate package Dog for @​Pet​::ISA at - line 3.
Can't locate package Dog for @​Pet​::ISA at - line 3.
Can't locate package Dog for @​Pet​::ISA at - line 3.


Flags​:
  category=core
  severity=low


Site configuration information for perl 5.13.3​:

Configured by sprout at Thu Aug 12 17​:53​:37 PDT 2010.

Summary of my perl5 (revision 5 version 13 subversion 3 patch v5.13.3-193-g798ae1b) configuration​:
  Snapshot of​: 798ae1b
  Platform​:
  osname=darwin, osvers=10.4.0, archname=darwin-2level
  uname='darwin pint.local 10.4.0 darwin kernel version 10.4.0​: fri apr 23 18​:28​:53 pdt 2010; root​:xnu-1504.7.4~1release_i386 i386 '
  config_args='-de -Dusedevel'
  hint=recommended, useposix=true, d_sigaction=define
  useithreads=undef, usemultiplicity=undef
  useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
  use64bitint=undef, use64bitall=undef, uselongdouble=undef
  usemymalloc=n, bincompat5005=undef
  Compiler​:
  cc='cc', ccflags ='-fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include',
  optimize='-O3',
  cppflags='-no-cpp-precomp -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
  ccversion='', gccversion='4.2.1 (Apple Inc. build 5664)', gccosandvers=''
  intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
  d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
  ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
  alignbytes=8, prototype=define
  Linker and Libraries​:
  ld='env MACOSX_DEPLOYMENT_TARGET=10.3 cc', ldflags =' -fstack-protector -L/usr/local/lib'
  libpth=/usr/local/lib /usr/lib
  libs=-ldbm -ldl -lm -lutil -lc
  perllibs=-ldl -lm -lutil -lc
  libc=/usr/lib/libc.dylib, so=dylib, useshrplib=false, libperl=libperl.a
  gnulibc_version=''
  Dynamic Linking​:
  dlsrc=dl_dlopen.xs, dlext=bundle, d_dlsymun=undef, ccdlflags=' '
  cccdlflags=' ', lddlflags=' -bundle -undefined dynamic_lookup -L/usr/local/lib -fstack-protector'

Locally applied patches​:
 


@​INC for perl 5.13.3​:
  /usr/local/lib/perl5/site_perl/5.13.3/darwin-2level
  /usr/local/lib/perl5/site_perl/5.13.3
  /usr/local/lib/perl5/5.13.3/darwin-2level
  /usr/local/lib/perl5/5.13.3
  /usr/local/lib/perl5/site_perl
  .


Environment for perl 5.13.3​:
  DYLD_LIBRARY_PATH (unset)
  HOME=/Users/sprout
  LANG=en_US.UTF-8
  LANGUAGE (unset)
  LD_LIBRARY_PATH (unset)
  LOGDIR (unset)
  PATH=/usr/bin​:/bin​:/usr/sbin​:/sbin​:/usr/local/bin​:/usr/X11/bin​:/usr/local/bin
  PERL_BADLANG (unset)
  SHELL=/bin/bash

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Oct 25, 2010

From @cpansprout

On Aug 22, 2010, at 12​:18 PM, Father Chrysostomos wrote​:

This little script (part of a test I’m preparing for part of bug #75176)—

use warnings;
{
@​Pet​::ISA = "Tike";
@​Tike​::ISA = "Barker";

sub Barker​::speak { "Woof!" }
sub Latrator​::speak { "Bow-wow!" }

my $pet = bless [], "Pet";

@​Dog​::ISA = 'Latrator';
my $tike_glob = delete $​::{'Tike​::'};
$​::{'Tike​::'} = delete $​::{'Dog​::'};

$pet->speak;

undef $tike_glob;
$pet->speak;
}

—produces these warnings, as of perl 5.10.0​:

Can't locate package Dog for @​Pet​::ISA at - line 18.
Can't locate package Dog for @​Pet​::ISA at - line 3.
Can't locate package Dog for @​Pet​::ISA at - line 3.
Can't locate package Dog for @​Pet​::ISA at - line 3.

It’s worse. A slight tweak to the script shows that the warnings are not erroneous, but show a real bug​: When Tike is aliased to Dog, Dog’s methods are ignored, but not those of its superclass.

use warnings;
{
@​Pet​::ISA = "Tike";
@​Tike​::ISA = "Barker";

sub Barker​::speak { warn "Woof!" }
sub Latrator​::speak { warn "Bow-wow!" }

my $pet = bless [], "Pet";

$pet->speak;

sub Dog​::speak { warn "Hello" }
@​Dog​::ISA = 'Latrator';
*Tike​:: = delete $​::{'Dog​::'};

$pet->speak;
}

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Oct 31, 2010

From @cpansprout

On Sun Oct 24 21​:59​:55 2010, some naughty individual wrote​:

It’s worse. A slight tweak to the script shows that the warnings are
not erroneous, but show a real bug​: When Tike is aliased to Dog, Dog’s
methods are ignored, but not those of its superclass.

use warnings;
{
@​Pet​::ISA = "Tike";
@​Tike​::ISA = "Barker";

sub Barker​::speak { warn "Woof!" }
sub Latrator​::speak { warn "Bow-wow!" }

my $pet = bless [], "Pet";

$pet->speak;

sub Dog​::speak { warn "Hello" }
@​Dog​::ISA = 'Latrator';
*Tike​:: = delete $​::{'Dog​::'};

$pet->speak;
}

Fixed by 8b9e80a.

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Oct 31, 2010

@cpansprout - Status changed from 'new' to 'resolved'

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.