Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Pod2man creates wrong ROFF esc sequences for Latin-1 characters. #10833

Closed
p5pRT opened this issue Nov 18, 2010 · 8 comments
Closed

Pod2man creates wrong ROFF esc sequences for Latin-1 characters. #10833

p5pRT opened this issue Nov 18, 2010 · 8 comments

Comments

@p5pRT
Copy link
Collaborator

@p5pRT p5pRT commented Nov 18, 2010

Migrated from rt.perl.org#79410 (status was 'rejected')

Searchable as RT79410$

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Nov 18, 2010

From waterlan@xs4all.nl

Created by waterlan@xs4all.nl

Hi,

I have a pod file encoded in Latin-1. The 8-bit Latin-1 characters
are converted wrongly to ROFF.

For instance an a-accute is translated to
  \*'
while it should be
  \['a]

An e with dieresis is translated to \*​: instead of \[​:e]

In fact all characters with dieresis are translated to \*​:
and all characters with accute to \*'
and with grave to \*`
and so on.

best regards,

Erwin Waterlander

PS
I have never used perlbug before, I hope I can attach a
file after this.
...
Sending mail with perlbug failed. I'm now sending with Thunderbird and
attach a test case.

Perl Info

Flags:
     category=utilities
     severity=high

Site configuration information for perl 5.10.1:

Configured by rurban at Sat Aug 28 20:14:06 CEST 2010.

Summary of my perl5 (revision 5 version 10 subversion 1) configuration:

   Platform:
     osname=cygwin, osvers=1.7.5(0.22553), 
archname=i686-cygwin-thread-multi-64int
     uname='cygwin_nt-5.1 reini 1.7.5(0.22553) 2010-04-12 19:07 i686 
cygwin '
     config_args='-de -Dlibperl=cygperl5_10.dll -Dcc=gcc-4 -Dld=g++-4 
-Dmksymlinks -Dusethreads -Dmad=y -Doptimize=-O3 -Accflags=-g3'
     hint=recommended, useposix=true, d_sigaction=define
     useithreads=define, usemultiplicity=define
     useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
     use64bitint=define, use64bitall=undef, uselongdouble=undef
     usemymalloc=y, bincompat5005=undef
   Compiler:
     cc='gcc-4', ccflags ='-DPERL_USE_SAFE_PUTENV -U__STRICT_ANSI__ -g3 
-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include',
     optimize='-O3',
     cppflags='-DPERL_USE_SAFE_PUTENV -U__STRICT_ANSI__ -g3 
-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
     ccversion='', gccversion='4.3.4 20090804 (release) 1', gccosandvers=''
     intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=12345678
     d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
     ivtype='long long', ivsize=8, nvtype='double', nvsize=8, 
Off_t='off_t', lseeksize=8
     alignbytes=8, prototype=define
   Linker and Libraries:
     ld='g++-4', ldflags =' -Wl,--enable-auto-import 
-Wl,--export-all-symbols -Wl,--stack,8388608 
-Wl,--enable-auto-image-base -fstack-protector -L/usr/local/lib'
     libpth=/usr/local/lib /usr/lib /lib
     libs=-lgdbm -ldb -ldl -lcrypt -lgdbm_compat
     perllibs=-ldl -lcrypt
     libc=/usr/lib/libc.a, so=dll, useshrplib=true, libperl=cygperl5_10.dll
     gnulibc_version=''
   Dynamic Linking:
     dlsrc=dl_dlopen.xs, dlext=dll, d_dlsymun=undef, ccdlflags=' '
     cccdlflags=' ', lddlflags=' --shared  -Wl,--enable-auto-import 
-Wl,--export-all-symbols -Wl,--stack,8388608 
-Wl,--enable-auto-image-base -L/usr/local/lib -fstack-protector'

Locally applied patches:
     CYG11 no-bs
     CYG12 no archlib in otherlibdirs
     CYG14 Dynaloader
     CYG15 static-Win32CORE
     CYG17 utf8-paths
     CYG21 LibList-Kid.patch
     CYG22 cygwin-1.7 hints
     CYG23 544-stat
     CYG24 build man pages
     CYG25 rebase_privlib
     Module-Build-0.36_13
     Bug#55162 CYG18 File::Spec::case_tolerant performance
     disable ExtUtils::MakeMaker::Coverage in Sys-Syslog


@INC for perl 5.10.1:
     /usr/lib/perl5/5.10/i686-cygwin
     /usr/lib/perl5/5.10
     /usr/lib/perl5/site_perl/5.10/i686-cygwin
     /usr/lib/perl5/site_perl/5.10
     /usr/lib/perl5/vendor_perl/5.10/i686-cygwin
     /usr/lib/perl5/vendor_perl/5.10
     /usr/lib/perl5/vendor_perl/5.10
     /usr/lib/perl5/site_perl/5.8
     /usr/lib/perl5/vendor_perl/5.8
     .


Environment for perl 5.10.1:
     HOME=/cygdrive/c/Users/waterlan
     LANG=nl_NL.UTF-8
     LANGUAGE (unset)
     LD_LIBRARY_PATH (unset)
     LOGDIR (unset)
     
PATH=/cygdrive/c/Users/waterlan/bin:/usr/local/bin:/usr/bin:/bin:/cygdrive/c/Program 
Files/PC Connectivity 
Solution/:/cygdrive/c/bin:/cygdrive/c/Windows/system32:/cygdrive/c/Windows:/cygdrive/c/Windows/System32/Wbem:/cygdrive/c/Windows/System32/WindowsPowerShell/v1.0/:/cygdrive/c/WATCOM18/BINNT:/cygdrive/c/WATCOM18/BINW
     PERL_BADLANG (unset)
     SHELL (unset)


@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Nov 18, 2010

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 7, 2012

From @jkeenan

On Thu Nov 18 13​:50​:04 2010, waterlan@​xs4all.nl wrote​:

This is a bug report for perl from waterlan@​xs4all.nl,
generated with the help of perlbug 1.39 running under perl 5.10.1.

I have a pod file encoded in Latin-1. The 8-bit Latin-1 characters
are converted wrongly to ROFF.

For instance an a-accute is translated to
\*'
while it should be
\['a]

An e with dieresis is translated to \*​: instead of \[​:e]

In fact all characters with dieresis are translated to \*​:
and all characters with accute to \*'
and with grave to \*`
and so on.

best regards,

Erwin Waterlander

PS
I have never used perlbug before, I hope I can attach a
file after this.
...
Sending mail with perlbug failed. I'm now sending with Thunderbird and
attach a test case.

Since Pod​::Man, as part of podlators, is now maintained on CPAN, I have
entered this issue into that distribution's bug queue​:

https://rt.cpan.org/Public/Bug/Display.html?id=73804

Should we close this ticket?

Thank you very much.
Jim Keenan

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 7, 2012

The RT System itself - Status changed from 'new' to 'open'

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 7, 2012

From @jkeenan

On Fri Jan 06 18​:35​:04 2012, jkeenan wrote​:

On Thu Nov 18 13​:50​:04 2010, waterlan@​xs4all.nl wrote​:

This is a bug report for perl from waterlan@​xs4all.nl,
generated with the help of perlbug 1.39 running under perl 5.10.1.

Since Pod​::Man, as part of podlators, is now maintained on CPAN, I have
entered this issue into that distribution's bug queue​:

https://rt.cpan.org/Public/Bug/Display.html?id=73804

Should we close this ticket?

We can close the ticket because one of the maintainers of podlators has
indeed picked up the ticket in the rt.cpan.org queue.

Thank you very much.
Jim Keenan

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 7, 2012

@jkeenan - Status changed from 'open' to 'rejected'

@p5pRT p5pRT closed this Jan 7, 2012
@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 7, 2012

From explorer@joaquinferrero.com

El 07/01/12 03​:35, James E Keenan via RT escribió​:

On Thu Nov 18 13​:50​:04 2010, waterlan@​xs4all.nl wrote​:

This is a bug report for perl from waterlan@​xs4all.nl,
generated with the help of perlbug 1.39 running under perl 5.10.1.

I have a pod file encoded in Latin-1. The 8-bit Latin-1 characters
are converted wrongly to ROFF.

For instance an a-accute is translated to
\*'
while it should be
\['a]

An e with dieresis is translated to \*​: instead of \[​:e]

In fact all characters with dieresis are translated to \*​:
and all characters with accute to \*'
and with grave to \*`
and so on.

best regards,

Erwin Waterlander

PS
I have never used perlbug before, I hope I can attach a
file after this.
...
Sending mail with perlbug failed. I'm now sending with Thunderbird and
attach a test case.

Since Pod​::Man, as part of podlators, is now maintained on CPAN, I have
entered this issue into that distribution's bug queue​:

https://rt.cpan.org/Public/Bug/Display.html?id=73804

Should we close this ticket?

Thank you very much.
Jim Keenan

---
via perlbug​: queue​: perl5 status​: new
https://rt-archive.perl.org/perl5/Ticket/Display.html?id=79410

I use this while pod2man is removed​:

Insert this line into $HOME/.bashrc file​:

export PERLDOC="-n \"perl -pe 'next if 1 .. /^[.]nh/; s{\(.\)\\\\\\\\\\\\\*\([​:~,\\\\047]\)}{\\\\\\\(\$2\$1}g' \| nroff -c \""

--
JF^D

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 9, 2012

From waterlan@xs4all.nl

Op 7-1-2012 4​:49, James E Keenan via RT schreef​:

On Fri Jan 06 18​:35​:04 2012, jkeenan wrote​:

On Thu Nov 18 13​:50​:04 2010, waterlan@​xs4all.nl wrote​:

This is a bug report for perl from waterlan@​xs4all.nl,
generated with the help of perlbug 1.39 running under perl 5.10.1.

Since Pod​::Man, as part of podlators, is now maintained on CPAN, I have
entered this issue into that distribution's bug queue​:

https://rt.cpan.org/Public/Bug/Display.html?id=73804

Should we close this ticket?

We can close the ticket because one of the maintainers of podlators has
indeed picked up the ticket in the rt.cpan.org queue.

Thank you very much.
Jim Keenan

Hi Jim,

Thanks for redirecting this problem to the correct location.

best regards,

--
Erwin Waterlander
www​: http​://www.xs4all.nl/~waterlan/

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.