Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

modules to be removed before 5.20.0 #12727

Closed
p5pRT opened this issue Jan 21, 2013 · 12 comments
Closed

modules to be removed before 5.20.0 #12727

p5pRT opened this issue Jan 21, 2013 · 12 comments
Labels

Comments

@p5pRT
Copy link
Collaborator

@p5pRT p5pRT commented Jan 21, 2013

Migrated from rt.perl.org#116491 (status was 'resolved')

Searchable as RT116491$

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 21, 2013

From @rjbs

The follow Perl libraries are identified for likely removal from the perl core
before 5.20.0​:

  * Archive​::Extract
  * B​::Lint
  * File​::CheckTree
  * Log​::Message
  * Log​::Message​::Simple
  * Module​::Pluggable
  * Object​::Accessor
  * Pod​::Parser [1]
  * Pod​::LaTeX
  * Pod​::Parser
  * Term​::UI
  * Text​::Soundex

Candidates that were given a pass for now were​:

  * IPC​::Cmd
  * Locale​::Maketext​::Simple
  * Params​::Check

1​: Pod​::Usage and Pod​::Checker would need scoped "no warnings" to avoid warning
  for now, since they will stay in, but use Pod​::Simple, in the future.

Next up​:

* supply patches to all upstream CPAN maintainers and request a new release
* patch all upstream=blead modules in perl core

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 21, 2013

From @rjbs

STATUS​:

* Archive​::Extract - needs patch
* B​::Lint - made upstream=CPAN; new release needed
* File​::CheckTree - file pull request​: rafl/file-checktree#1
* Log​::Message - needs patch
* Log​::Message​::Simple - needs patch
* Module​::Pluggable - needs patch
* Object​::Accessor - needs patch
* Pod​::Parser [1] -- It's Complicated
* Pod​::LaTeX - "use deprecate" added in CPAN and core, done!
* Term​::UI - needs patch
* Text​::Soundex - patch written, needs release​: https://github.com/rjbs/Text-Soundex

--
rjbs

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 21, 2013

@rjbs - Status changed from 'new' to 'open'

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 21, 2013

From @Tux

On Mon, 21 Jan 2013 14​:58​:12 -0800, Ricardo SIGNES (via RT)
<perlbug-followup@​perl.org> wrote​:

# New Ticket Created by Ricardo SIGNES
# Please include the string​: [perl #116491]
# in the subject line of all future correspondence about this issue.
# <URL​: https://rt-archive.perl.org/perl5/Ticket/Display.html?id=116491 >

The follow Perl libraries are identified for likely removal from the perl core
before 5.20.0​:

* Archive​::Extract
* B​::Lint
* File​::CheckTree
* Log​::Message
* Log​::Message​::Simple
* Module​::Pluggable
* Object​::Accessor
* Pod​::Parser [1]
* Pod​::LaTeX
* Pod​::Parser
* Term​::UI
* Text​::Soundex

  * CGI ?

Candidates that were given a pass for now were​:

* IPC​::Cmd
* Locale​::Maketext​::Simple
* Params​::Check

1​: Pod​::Usage and Pod​::Checker would need scoped "no warnings" to avoid warning
for now, since they will stay in, but use Pod​::Simple, in the future.

Next up​:

* supply patches to all upstream CPAN maintainers and request a new release
* patch all upstream=blead modules in perl core

--
H.Merijn Brand http​://tux.nl Perl Monger http​://amsterdam.pm.org/
using perl5.00307 .. 5.17 porting perl5 on HP-UX, AIX, and openSUSE
http​://mirrors.develooper.com/hpux/ http​://www.test-smoke.org/
http​://qa.perl.org http​://www.goldmark.org/jeff/stupid-disclaimers/

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 21, 2013

From @rjbs

Modules yet to be dealt with​:

* Archive​::Extract - jib/archive-extract#4
* B​::Lint - made upstream=CPAN; new release needed
* File​::CheckTree - file pull request​: rafl/file-checktree#1
* Log​::Message - jib/log-message#1
* Log​::Message​::Simple - jib/log-message-simple#1
* Module​::Pluggable - simonwistow/Module-Pluggable#3
* Object​::Accessor - jib/object-accessor#2
* Pod​::Parser [1] -- It's Complicated
* Term​::UI - jib/term-ui#4
* Text​::Soundex - patch written, needs release​: https://github.com/rjbs/Text-Soundex

--
rjbs

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Jan 24, 2013

From @rjbs

Complicated situations​:

* Pod-Parser

Modules patched but not released​:

* Archive-Extract - jib/archive-extract#4
* B-Lint - rafl/B-Lint#2
* File-CheckTree - rafl/file-checktree#1
* Text-Soundex - https://github.com/rjbs/Text-Soundex

Dists released to CPAN but not yet in blead​:

* Module-Pluggable

Dists with deprecate.pm in core, waiting for 5.19.0​:

* CPANPLUS
* Log-Message
* Log-Message​::Simple
* Object-Accessor
* Pod​::LaTeX
* Term-UI

--
rjbs

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Feb 8, 2013

From @rjbs

Complicated situations​:

* Pod-Parser

Modules patched but not released​:

Dists with deprecate.pm in core, waiting for 5.19.0​:

* Archive-Extract
* B-Lint
* CPANPLUS
* File-CheckTree
* Log-Message
* Log-Message​::Simple
* Module-Pluggable
* Object-Accessor
* Pod​::LaTeX
* Term-UI
* Text-Soundex

--
rjbs

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Feb 8, 2013

From @rjbs

I have removed this ticket from blocking 5.18.0, and it can be resolved shortly thereafter.

--
rjbs

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Aug 2, 2013

From @jkeenan

On Fri Feb 08 07​:32​:26 2013, rjbs wrote​:

I have removed this ticket from blocking 5.18.0, and it can be
resolved shortly thereafter.

rjbs​: Is this ticket closable? If not, what remains to be done.

Thank you very much.
jimk

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Aug 23, 2013

From @rjbs

Closed. I'll make (or find) a new ticket to deal with sorting out the final steps of Pod​::Parser.

--
rjbs

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Aug 23, 2013

From [Unknown Contact. See original ticket]

Closed. I'll make (or find) a new ticket to deal with sorting out the final steps of Pod​::Parser.

--
rjbs

@p5pRT
Copy link
Collaborator Author

@p5pRT p5pRT commented Aug 23, 2013

@rjbs - Status changed from 'open' to 'resolved'

@p5pRT p5pRT closed this Aug 23, 2013
@p5pRT p5pRT added the Severity Low label Oct 19, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.