Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Blead Breaks CPAN: FELIPE/Crypt-Perl-0.17.tar.gz #16434

Closed
p5pRT opened this issue Feb 22, 2018 · 14 comments
Closed

Blead Breaks CPAN: FELIPE/Crypt-Perl-0.17.tar.gz #16434

p5pRT opened this issue Feb 22, 2018 · 14 comments

Comments

@p5pRT
Copy link

@p5pRT p5pRT commented Feb 22, 2018

Migrated from rt.perl.org#132900 (status was 'resolved')

Searchable as RT132900$

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 22, 2018

From @eserte

This is a bug report for perl from slaven@​rezic.de,
generated with the help of perlbug 1.41 running under perl 5.27.9.


The t/Crypt-Perl-RSA-PrivateKey.t in Crypt-Perl-0.17 fails with
perl 5.27.9 (and also 5.27.8-157-gef80cd9). The last released perl
with passes was perl 5.27.5 (and it passes also with
5.27.5-170-ga385812b68). There are no results in between because of
dependency build problems.

Sample reports​:
http​://fast-matrix.cpantesters.org/?dist=Crypt-Perl%200.17;perl=5.27.9;reports=1



Flags​:
  category=core
  severity=low


Site configuration information for perl 5.27.9​:

Configured by eserte at Tue Feb 20 21​:59​:42 CET 2018.

Summary of my perl5 (revision 5 version 27 subversion 9) configuration​:
 
  Platform​:
  osname=linux
  osvers=3.16.0-4-amd64
  archname=x86_64-linux
  uname='linux cabulja 3.16.0-4-amd64 #1 smp debian 3.16.51-3 (2017-12-13) x86_64 gnulinux '
  config_args='-ds -e -Dprefix=/opt/perl-5.27.9 -Dusedevel -Dusemallocwrap=no -Dcf_email=srezic@​cpan.org'
  hint=recommended
  useposix=true
  d_sigaction=define
  useithreads=undef
  usemultiplicity=undef
  use64bitint=define
  use64bitall=define
  uselongdouble=undef
  usemymalloc=n
  default_inc_excludes_dot=define
  bincompat5005=undef
  Compiler​:
  cc='cc'
  ccflags ='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2'
  optimize='-O2'
  cppflags='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
  ccversion=''
  gccversion='4.9.2'
  gccosandvers=''
  intsize=4
  longsize=8
  ptrsize=8
  doublesize=8
  byteorder=12345678
  doublekind=3
  d_longlong=define
  longlongsize=8
  d_longdbl=define
  longdblsize=16
  longdblkind=3
  ivtype='long'
  ivsize=8
  nvtype='double'
  nvsize=8
  Off_t='off_t'
  lseeksize=8
  alignbytes=8
  prototype=define
  Linker and Libraries​:
  ld='cc'
  ldflags =' -fstack-protector-strong -L/usr/local/lib'
  libpth=/usr/local/lib /usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed /usr/include/x86_64-linux-gnu /usr/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib
  libs=-lpthread -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
  perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
  libc=libc-2.19.so
  so=so
  useshrplib=false
  libperl=libperl.a
  gnulibc_version='2.19'
  Dynamic Linking​:
  dlsrc=dl_dlopen.xs
  dlext=so
  d_dlsymun=undef
  ccdlflags='-Wl,-E'
  cccdlflags='-fPIC'
  lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector-strong'


@​INC for perl 5.27.9​:
  /opt/perl-5.27.9/lib/site_perl/5.27.9/x86_64-linux
  /opt/perl-5.27.9/lib/site_perl/5.27.9
  /opt/perl-5.27.9/lib/5.27.9/x86_64-linux
  /opt/perl-5.27.9/lib/5.27.9


Environment for perl 5.27.9​:
  HOME=/home/eserte
  LANG=en_US.UTF-8
  LANGUAGE (unset)
  LD_LIBRARY_PATH (unset)
  LOGDIR (unset)
  PATH=/usr/local/bin​:/usr/bin​:/bin​:/usr/local/sbin​:/usr/sbin​:/sbin​:/home/eserte/bin/linux-gnu​:/home/eserte/bin/sh​:/home/eserte/bin​:/home/eserte/bin/pistachio-perl/bin​:/usr/games​:/home/eserte/devel
  PERLDOC=-MPod​::Perldoc​::ToTextOverstrike
  PERL_BADLANG (unset)
  SHELL=/bin/zsh

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 23, 2018

From zefram@fysh.org

The failing dep isn't used by the failing test, so it's not too difficult
to explore the intermediate versions. The test passes on 5.27.8.
The problem bisects to commit ab1efbd
"regexec.c​: Use word-at-a-time to repeat a single byte pattern".
The test case reduces to

$ perl5.27.8 -lwe 'print +("\x80" x 9) =~ m<\A\x80+\z> ? "yes" : "no"'
yes
$ perl5.27.9 -lwe 'print +("\x80" x 9) =~ m<\A\x80+\z> ? "yes" : "no"'
no

Clearly a newly-introduced core bug.

-zefram

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 23, 2018

The RT System itself - Status changed from 'new' to 'open'

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 23, 2018

From @demerphq

On 23 Feb 2018 08​:12, "Zefram" <zefram@​fysh.org> wrote​:

The failing dep isn't used by the failing test, so it's not too difficult
to explore the intermediate versions. The test passes on 5.27.8.
The problem bisects to commit ab1efbd
"regexec.c​: Use word-at-a-time to repeat a single byte pattern".
The test case reduces to

$ perl5.27.8 -lwe 'print +("\x80" x 9) =~ m<\A\x80+\z> ? "yes" : "no"'
yes
$ perl5.27.9 -lwe 'print +("\x80" x 9) =~ m<\A\x80+\z> ? "yes" : "no"'
no

Clearly a newly-introduced core bug.

No doubt Karl will fix this soon.

Yves

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 23, 2018

From @khwilliamson

On 02/22/2018 05​:11 PM, Zefram wrote​:

The failing dep isn't used by the failing test, so it's not too difficult
to explore the intermediate versions. The test passes on 5.27.8.
The problem bisects to commit ab1efbd
"regexec.c​: Use word-at-a-time to repeat a single byte pattern".
The test case reduces to

$ perl5.27.8 -lwe 'print +("\x80" x 9) =~ m<\A\x80+\z> ? "yes" : "no"'
yes
$ perl5.27.9 -lwe 'print +("\x80" x 9) =~ m<\A\x80+\z> ? "yes" : "no"'
no

Clearly a newly-introduced core bug.

-zefram

Now fixed by 2b1f9c7
The cause was using a 'char' instead of the proper 'U8'.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 23, 2018

From @khwilliamson

Thanks for reporting this, and thanks to Zefram for reducing the problem
This is fixed by 2b1f9c7
--
Karl Williamson

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 23, 2018

@khwilliamson - Status changed from 'open' to 'resolved'

@p5pRT p5pRT closed this as completed Feb 23, 2018
@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 25, 2018

From @eserte

This is a bug report for perl from slaven@​rezic.de,
generated with the help of perlbug 1.41 running under perl 5.27.9.


The test t/10read-block.t of Device-Chip-SDCard-0.01 started to
fail with perl 5.27.9​:

Unexpected call to ->release_ss() at /home/cpansand/.cpan/build/2018022415/Device-Chip-SDCard-0.01-0/blib/lib/Device/Chip/SDCard.pm line 213.
# Tests were run but no plan was declared and done_testing() was not seen.
# Looks like your test exited with 255 just after 2.
t/10read-block.t ....
Dubious, test returned 255 (wstat 65280, 0xff00)
All 2 subtests passed

An overview of CPAN Testers reports​:
http​://fast-matrix.cpantesters.org/?dist=Device-Chip-SDCard%200.01



Flags​:
  category=core
  severity=low


Site configuration information for perl 5.27.9​:

Configured by eserte at Tue Feb 20 21​:59​:42 CET 2018.

Summary of my perl5 (revision 5 version 27 subversion 9) configuration​:
 
  Platform​:
  osname=linux
  osvers=3.16.0-4-amd64
  archname=x86_64-linux
  uname='linux cabulja 3.16.0-4-amd64 #1 smp debian 3.16.51-3 (2017-12-13) x86_64 gnulinux '
  config_args='-ds -e -Dprefix=/opt/perl-5.27.9 -Dusedevel -Dusemallocwrap=no -Dcf_email=srezic@​cpan.org'
  hint=recommended
  useposix=true
  d_sigaction=define
  useithreads=undef
  usemultiplicity=undef
  use64bitint=define
  use64bitall=define
  uselongdouble=undef
  usemymalloc=n
  default_inc_excludes_dot=define
  bincompat5005=undef
  Compiler​:
  cc='cc'
  ccflags ='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2'
  optimize='-O2'
  cppflags='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
  ccversion=''
  gccversion='4.9.2'
  gccosandvers=''
  intsize=4
  longsize=8
  ptrsize=8
  doublesize=8
  byteorder=12345678
  doublekind=3
  d_longlong=define
  longlongsize=8
  d_longdbl=define
  longdblsize=16
  longdblkind=3
  ivtype='long'
  ivsize=8
  nvtype='double'
  nvsize=8
  Off_t='off_t'
  lseeksize=8
  alignbytes=8
  prototype=define
  Linker and Libraries​:
  ld='cc'
  ldflags =' -fstack-protector-strong -L/usr/local/lib'
  libpth=/usr/local/lib /usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed /usr/include/x86_64-linux-gnu /usr/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib
  libs=-lpthread -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
  perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
  libc=libc-2.19.so
  so=so
  useshrplib=false
  libperl=libperl.a
  gnulibc_version='2.19'
  Dynamic Linking​:
  dlsrc=dl_dlopen.xs
  dlext=so
  d_dlsymun=undef
  ccdlflags='-Wl,-E'
  cccdlflags='-fPIC'
  lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector-strong'


@​INC for perl 5.27.9​:
  /opt/perl-5.27.9/lib/site_perl/5.27.9/x86_64-linux
  /opt/perl-5.27.9/lib/site_perl/5.27.9
  /opt/perl-5.27.9/lib/5.27.9/x86_64-linux
  /opt/perl-5.27.9/lib/5.27.9


Environment for perl 5.27.9​:
  HOME=/home/eserte
  LANG=en_US.UTF-8
  LANGUAGE (unset)
  LD_LIBRARY_PATH (unset)
  LOGDIR (unset)
  PATH=/usr/local/bin​:/usr/bin​:/bin​:/usr/local/sbin​:/usr/sbin​:/sbin​:/home/eserte/bin/linux-gnu​:/home/eserte/bin/sh​:/home/eserte/bin​:/home/eserte/bin/pistachio-perl/bin​:/usr/games​:/home/eserte/devel
  PERLDOC=-MPod​::Perldoc​::ToTextOverstrike
  PERL_BADLANG (unset)
  SHELL=/bin/zsh

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 25, 2018

From zefram@fysh.org

slaven@​rezic.de wrote​:

The test t/10read-block.t of Device-Chip-SDCard-0.01 started to
fail with perl 5.27.9​:

Bisection shows that the problem was introduced by commit
ab1efbd "regexec.c​: Use word-at-a-time
to repeat a single byte pattern" and was unsurprisingly fixed by
commit 2b1f9c7 "PATCH​: [perl #132900]
Blead Breaks CPAN​: FELIPE/Crypt-Perl". This is an also-broke for
[perl #132900].

-zefram

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 25, 2018

The RT System itself - Status changed from 'new' to 'open'

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 25, 2018

From @eserte

"Zefram via RT" <perlbug-followup@​perl.org> writes​:

slaven@​rezic.de wrote​:

The test t/10read-block.t of Device-Chip-SDCard-0.01 started to
fail with perl 5.27.9​:

Bisection shows that the problem was introduced by commit
ab1efbd "regexec.c​: Use word-at-a-time
to repeat a single byte pattern" and was unsurprisingly fixed by
commit 2b1f9c7 "PATCH​: [perl #132900]
Blead Breaks CPAN​: FELIPE/Crypt-Perl". This is an also-broke for
[perl #132900].

I can confirm a pass with a 5.27.9+ build (more specific​: with
5.27.8-374-gc4a2ac4 it's fine).

--
Slaven Rezic - slaven <at> rezic <dot> de

  Berlin Perl Mongers - http​://berlin.pm.org

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 25, 2018

@cpansprout - Status changed from 'open' to 'resolved'

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 25, 2018

From @khwilliamson

On 02/25/2018 12​:59 PM, Slaven Rezic wrote​:

"Zefram via RT" <perlbug-followup@​perl.org> writes​:

slaven@​rezic.de wrote​:

The test t/10read-block.t of Device-Chip-SDCard-0.01 started to
fail with perl 5.27.9​:

Bisection shows that the problem was introduced by commit
ab1efbd "regexec.c​: Use word-at-a-time
to repeat a single byte pattern" and was unsurprisingly fixed by
commit 2b1f9c7 "PATCH​: [perl #132900]
Blead Breaks CPAN​: FELIPE/Crypt-Perl". This is an also-broke for
[perl #132900].

I can confirm a pass with a 5.27.9+ build (more specific​: with
5.27.8-374-gc4a2ac4 it's fine).

Merged into 132900

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 26, 2018

From @eserte

Dana Sun, 25 Feb 2018 12​:55​:48 -0800, public@​khwilliamson.com reče​:

On 02/25/2018 12​:59 PM, Slaven Rezic wrote​:

"Zefram via RT" <perlbug-followup@​perl.org> writes​:

slaven@​rezic.de wrote​:

The test t/10read-block.t of Device-Chip-SDCard-0.01 started to
fail with perl 5.27.9​:

Bisection shows that the problem was introduced by commit
ab1efbd "regexec.c​: Use word-at-a-time
to repeat a single byte pattern" and was unsurprisingly fixed by
commit 2b1f9c7 "PATCH​: [perl #132900]
Blead Breaks CPAN​: FELIPE/Crypt-Perl". This is an also-broke for
[perl #132900].

I can confirm a pass with a 5.27.9+ build (more specific​: with
5.27.8-374-gc4a2ac4 it's fine).

Merged into 132900

Just for completeness​: a regexp test in YAKEX/Getopt-Config-FromPod-v0.0.3.tar.gz also failed with 5.27.9 and is fixed in a later version (checked 5.27.8-403-g9fa1876), maybe it was the same issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

1 participant