Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Devel::PPPort migration to dist/ is incomplete #16438

Closed
p5pRT opened this issue Feb 24, 2018 · 24 comments
Closed

Devel::PPPort migration to dist/ is incomplete #16438

p5pRT opened this issue Feb 24, 2018 · 24 comments

Comments

@p5pRT
Copy link

@p5pRT p5pRT commented Feb 24, 2018

Migrated from rt.perl.org#132906 (status was 'resolved')

Searchable as RT132906$

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 24, 2018

From @dur-randir

Created by @dur-randir

Since the commit [1], Devel​::PPPort resides under dist/ which,
presumably, means that it's now blead-upstream. But there're some
things unchanged from the times when it was cpan-upstream​:

- CPAN still points to github [2] for both module's sources and bug tracker
- there're 12 open issues and 5 pull requests pending
- P5P doesn't have upload permissions for it on CPAN

What are the next steps to be taken? Who should take them?

[1] commit 7baf245
Author​: Karl Williamson <khw@​cpan.org>
Date​: Tue Oct 17 06​:54​:57 2017 -0600

  mv Devel-PPPort from cpan to dist

  It was decided at the perl core hackathon in October 2017 to go ahead
  and do this.

[2] https://github.com/mhx/Devel-PPPort/

Perl Info

Flags:
    category=library
    severity=low
    module=Devel::PPPort

Site configuration information for perl 5.27.9:

Configured by root at Sun Feb 11 01:07:53 MSK 2018.

Summary of my perl5 (revision 5 version 27 subversion 9) configuration:
  Commit id: c0e3b4b51cabf15ed8fc5f564dfeea31c25f5239
  Platform:
    osname=linux
    osvers=4.9.0-5-amd64
    archname=x86_64-linux
    uname='linux dorothy 4.9.0-5-amd64 #1 smp debian 4.9.65-3+deb9u2
(2018-01-04) x86_64 gnulinux '
    config_args='-de -Dusedevel'
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=undef
    usemultiplicity=undef
    use64bitint=define
    use64bitall=define
    uselongdouble=undef
    usemymalloc=n
    default_inc_excludes_dot=define
    bincompat5005=undef
  Compiler:
    cc='cc'
    ccflags ='-fwrapv -fno-strict-aliasing -pipe
-fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2'
    optimize='-O2'
    cppflags='-fwrapv -fno-strict-aliasing -pipe
-fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='6.3.0 20170516'
    gccosandvers=''
    intsize=4
    longsize=8
    ptrsize=8
    doublesize=8
    byteorder=12345678
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=16
    longdblkind=3
    ivtype='long'
    ivsize=8
    nvtype='double'
    nvsize=8
    Off_t='off_t'
    lseeksize=8
    alignbytes=8
    prototype=define
  Linker and Libraries:
    ld='cc'
    ldflags =' -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/local/lib
/usr/lib/gcc/x86_64-linux-gnu/6/include-fixed
/usr/include/x86_64-linux-gnu /usr/lib /lib/x86_64-linux-gnu
/lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib
    libs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.24.so
    so=so
    useshrplib=false
    libperl=libperl.a
    gnulibc_version='2.24'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=so
    d_dlsymun=undef
    ccdlflags='-Wl,-E'
    cccdlflags='-fPIC'
    lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector-strong'



@INC for perl 5.27.9:
    lib
    /usr/local/lib/perl5/site_perl/5.27.9/x86_64-linux
    /usr/local/lib/perl5/site_perl/5.27.9
    /usr/local/lib/perl5/5.27.9/x86_64-linux
    /usr/local/lib/perl5/5.27.9


Environment for perl 5.27.9:
    HOME=/home/afl
    LANG=en_US.UTF-8
    LANGUAGE=en_US:en
    LC_CTYPE=en_US.UTF-8
    LD_LIBRARY_PATH (unset)
    LOGDIR (unset)
    PATH=/home/afl/perlbrew/bin:/home/afl/perlbrew/perls/perl-5.20.2/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
    PERLBREW_BASHRC_VERSION=0.78
    PERLBREW_HOME=/home/afl/.perlbrew
    PERLBREW_MANPATH=/home/afl/perlbrew/perls/perl-5.20.2/man
    PERLBREW_PATH=/home/afl/perlbrew/bin:/home/afl/perlbrew/perls/perl-5.20.2/bin
    PERLBREW_PERL=perl-5.20.2
    PERLBREW_ROOT=/home/afl/perlbrew
    PERLBREW_VERSION=0.78
    PERL_BADLANG (unset)
    SHELL=/usr/bin/zsh

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 26, 2018

From @xsawyerx

On Sat, 24 Feb 2018 10​:48​:58 -0800, randir wrote​:

This is a bug report for perl from sergey.aleynikov@​gmail.com,
generated with the help of perlbug 1.41 running under perl 5.27.9.

-----------------------------------------------------------------
[Please describe your issue here]

Since the commit [1], Devel​::PPPort resides under dist/ which,
presumably, means that it's now blead-upstream. But there're some
things unchanged from the times when it was cpan-upstream​:

- CPAN still points to github [2] for both module's sources and bug
tracker
- there're 12 open issues and 5 pull requests pending
- P5P doesn't have upload permissions for it on CPAN

What are the next steps to be taken? Who should take them?

We need to determine what level of backwards compatibility Devel​::PPPort provides. At the moment this i 5.3.x, which is hard to maintain (and provides little value consider toolchain doesn't support back to it).

Then we need to transfer ownership (or at least comaint) to P5P so we could make releases. Then we would like to make sure we know how to test it and release it. The testing phase requires building the Perl versions and testing the code on all of them.

We are waiting for mhx for the first item. We had little luck in reaching him so far.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 26, 2018

The RT System itself - Status changed from 'new' to 'open'

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 26, 2018

From @Tux

On Mon, 26 Feb 2018 03​:10​:06 -0800, "Sawyer X via RT"
<perlbug-followup@​perl.org> wrote​:

On Sat, 24 Feb 2018 10​:48​:58 -0800, randir wrote​:

This is a bug report for perl from sergey.aleynikov@​gmail.com,

Since the commit [1], Devel​::PPPort resides under dist/ which,
presumably, means that it's now blead-upstream. But there're some
things unchanged from the times when it was cpan-upstream​:

- CPAN still points to github [2] for both module's sources and
bug tracker
- there're 12 open issues and 5 pull requests pending
- P5P doesn't have upload permissions for it on CPAN

What are the next steps to be taken? Who should take them?

We need to determine what level of backwards compatibility
Devel​::PPPort provides. At the moment this i 5.3.x, which is hard to
maintain (and provides little value consider toolchain doesn't
support back to it).

If Devel​::PPPort raises its own major version number when minimum
support is raised to 5.6.1, I think everyone would understand. I
remember how much simpler my XS code got when removing 5.005 support.

@​Peter, does that sound feasible, or do you still use 5.005 with
Devel​::PPPort?

Then we need to transfer ownership (or at least comaint) to P5P so we
could make releases. Then we would like to make sure we know how to
test it and release it. The testing phase requires building the Perl
versions and testing the code on all of them.

We are waiting for mhx for the first item. We had little luck in
reaching him so far.

--
H.Merijn Brand http​://tux.nl Perl Monger http​://amsterdam.pm.org/
using perl5.00307 .. 5.27 porting perl5 on HP-UX, AIX, and openSUSE
http​://mirrors.develooper.com/hpux/ http​://www.test-smoke.org/
http​://qa.perl.org http​://www.goldmark.org/jeff/stupid-disclaimers/

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 27, 2018

From @ribasushi

On 02/26/2018 12​:24 PM, H.Merijn Brand wrote​:

@​Peter, does that sound feasible, or do you still use 5.005 with
Devel​::PPPort?

Yes, minimum of 5.6.1 ( note​: .1 not .2 ) is reasonable.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 27, 2018

From @Tux

On Tue, 27 Feb 2018 12​:24​:19 +0100, Peter Rabbitson
<rabbit-p5p@​rabbit.us> wrote​:

On 02/26/2018 12​:24 PM, H.Merijn Brand wrote​:

@​Peter, does that sound feasible, or do you still use 5.005 with
Devel​::PPPort?

Yes, minimum of 5.6.1 ( note​: .1 not .2 ) is reasonable.

Makes sense, even though a *new* build is most likely to FAIL on 5.6.1
but adding XS to an *existing* 5.6.1 is likely to happen in "the real
world"

So my 👍/ +1 for dropping all support for perl < 5.6.1 in Devel​::PPPort

--
H.Merijn Brand http​://tux.nl Perl Monger http​://amsterdam.pm.org/
using perl5.00307 .. 5.27 porting perl5 on HP-UX, AIX, and openSUSE
http​://mirrors.develooper.com/hpux/ http​://www.test-smoke.org/
http​://qa.perl.org http​://www.goldmark.org/jeff/stupid-disclaimers/

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 28, 2018

From @xsawyerx

On 02/27/2018 01​:44 PM, H.Merijn Brand wrote​:

On Tue, 27 Feb 2018 12​:24​:19 +0100, Peter Rabbitson
<rabbit-p5p@​rabbit.us> wrote​:

On 02/26/2018 12​:24 PM, H.Merijn Brand wrote​:

@​Peter, does that sound feasible, or do you still use 5.005 with
Devel​::PPPort?

Yes, minimum of 5.6.1 ( note​: .1 not .2 ) is reasonable.
Makes sense, even though a *new* build is most likely to FAIL on 5.6.1
but adding XS to an *existing* 5.6.1 is likely to happen in "the real
world"

So my 👍/ +1 for dropping all support for perl < 5.6.1 in Devel​::PPPort

In a conversation with the previous maintainer of Devel​::PPPort,
Matthew, we agreed on using the latest version supported by the
toolchain, but I see no reason not to start at 5.6.1 and raise this
topic again if we see this poses a problem.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 28, 2018

From @xsawyerx

On 02/28/2018 01​:33 PM, Sawyer X wrote​:

On 02/27/2018 01​:44 PM, H.Merijn Brand wrote​:

On Tue, 27 Feb 2018 12​:24​:19 +0100, Peter Rabbitson
<rabbit-p5p@​rabbit.us> wrote​:

On 02/26/2018 12​:24 PM, H.Merijn Brand wrote​:

@​Peter, does that sound feasible, or do you still use 5.005 with
Devel​::PPPort?

Yes, minimum of 5.6.1 ( note​: .1 not .2 ) is reasonable.
Makes sense, even though a *new* build is most likely to FAIL on 5.6.1
but adding XS to an *existing* 5.6.1 is likely to happen in "the real
world"

So my 👍/ +1 for dropping all support for perl < 5.6.1 in Devel​::PPPort
In a conversation with the previous maintainer of Devel​::PPPort,
Matthew, we agreed on using the latest version supported by the
toolchain, but I see no reason not to start at 5.6.1 and raise this
topic again if we see this poses a problem.

No, I was wrong. I found emails in which I explicitly said "< 5.6".

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Feb 28, 2018

From @xsawyerx

On 02/26/2018 01​:10 PM, Sawyer X via RT wrote​:

On Sat, 24 Feb 2018 10​:48​:58 -0800, randir wrote​:

This is a bug report for perl from sergey.aleynikov@​gmail.com,
generated with the help of perlbug 1.41 running under perl 5.27.9.

-----------------------------------------------------------------
[Please describe your issue here]

Since the commit [1], Devel​::PPPort resides under dist/ which,
presumably, means that it's now blead-upstream. But there're some
things unchanged from the times when it was cpan-upstream​:

- CPAN still points to github [2] for both module's sources and bug
tracker
- there're 12 open issues and 5 pull requests pending
- P5P doesn't have upload permissions for it on CPAN

What are the next steps to be taken? Who should take them?
We need to determine what level of backwards compatibility Devel​::PPPort provides. At the moment this i 5.3.x, which is hard to maintain (and provides little value consider toolchain doesn't support back to it).

Then we need to transfer ownership (or at least comaint) to P5P so we could make releases. Then we would like to make sure we know how to test it and release it. The testing phase requires building the Perl versions and testing the code on all of them.

We are waiting for mhx for the first item. We had little luck in reaching him so far.

I have spoken to mhx. He has added P5P as a PAUSE as firstcome, so we
can make new releases. We have also agreed on dropping support for
anything under 5.6.1, as noted in the thread.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 25, 2018

From @dur-randir

I've attached a patch to this message that changes RT and other urls for Devel​::PPPort to point to perl's own ones.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 25, 2018

From @dur-randir

0001-Update-RT-path-for-Devel-PPPort.patch
From 4a38f8e7a6a2cc488a8c9bcb99c3a4ad1e556a66 Mon Sep 17 00:00:00 2001
From: Sergey Aleynikov <sergey.aleynikov@gmail.com>
Date: Mon, 26 Mar 2018 02:05:47 +0300
Subject: [PATCH] Update RT path for Devel::PPPort

---
 dist/Devel-PPPort/Makefile.PL | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/dist/Devel-PPPort/Makefile.PL b/dist/Devel-PPPort/Makefile.PL
index 25e352e641..b67800dfa2 100644
--- a/dist/Devel-PPPort/Makefile.PL
+++ b/dist/Devel-PPPort/Makefile.PL
@@ -39,14 +39,9 @@ WriteMakefile(
       version => 2,
     },
     resources => {
-      bugtracker => {
-        web => 'https://github.com/mhx/Devel-PPPort/issues/',
-      },
-      repository => {
-        type => 'git',
-        url  => 'git://github.com/mhx/Devel-PPPort.git',
-        web  => 'https://github.com/mhx/Devel-PPPort/',
-      },
+        repository => 'git://perl5.git.perl.org/perl.git',
+        bugtracker => 'https://rt.perl.org/rt3/',
+        homepage   => "http://dev.perl.org/",
     },
   },
 );
-- 
2.14.2

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 26, 2018

From @Grinnz

On Sun, Mar 25, 2018 at 7​:06 PM, Sergey Aleynikov via RT <
perlbug-followup@​perl.org> wrote​:

I've attached a patch to this message that changes RT and other urls for
Devel​::PPPort to point to perl's own ones.

---
via perlbug​: queue​: perl5 status​: open
https://rt-archive.perl.org/perl5/Ticket/Display.html?id=132906

From 4a38f8e7a6a2cc488a8c9bcb99c3a4ad1e556a66 Mon Sep 17 00​:00​:00 2001
From​: Sergey Aleynikov <sergey.aleynikov@​gmail.com>
Date​: Mon, 26 Mar 2018 02​:05​:47 +0300
Subject​: [PATCH] Update RT path for Devel​::PPPort

---
dist/Devel-PPPort/Makefile.PL | 11 +++--------
1 file changed, 3 insertions(+), 8 deletions(-)

diff --git a/dist/Devel-PPPort/Makefile.PL b/dist/Devel-PPPort/Makefile.PL
index 25e352e641..b67800dfa2 100644
--- a/dist/Devel-PPPort/Makefile.PL
+++ b/dist/Devel-PPPort/Makefile.PL
@​@​ -39,14 +39,9 @​@​ WriteMakefile(
version => 2,
},
resources => {
- bugtracker => {
- web => 'https://github.com/mhx/Devel-PPPort/issues/',
- },
- repository => {
- type => 'git',
- url => 'git​://github.com/mhx/Devel-PPPort.git',
- web => 'https://github.com/mhx/Devel-PPPort/',
- },
+ repository => 'git​://perl5.git.perl.org/perl.git',
+ bugtracker => 'https://rt-archive.perl.org/perl5/',
+ homepage => "http​://dev.perl.org/",
},
},
);
--
2.14.2

This is incorrect for meta-spec version 2. You should stick to the
original format.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 26, 2018

From @dur-randir

On Sun, 25 Mar 2018 18​:36​:06 -0700, grinnz@​gmail.com wrote​:

This is incorrect for meta-spec version 2. You should stick to the
original format.

Here's an updated patch series that also includes updates in other places in the docs mentioning github.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 26, 2018

From @dur-randir

0002-Update-links-in-Devel-PPPort-documentation.patch
From b706d31c69be5b0bd1744acdd78f7be5d59c8c0a Mon Sep 17 00:00:00 2001
From: Sergey Aleynikov <sergey.aleynikov@gmail.com>
Date: Mon, 26 Mar 2018 23:39:45 +0300
Subject: [PATCH 2/2] Update links in Devel::PPPort documentation

So they no longer point to github, as it's now maintained in-core.
---
 dist/Devel-PPPort/HACKERS           | 5 ++---
 dist/Devel-PPPort/PPPort_pm.PL      | 3 +--
 dist/Devel-PPPort/parts/inc/ppphdoc | 2 +-
 3 files changed, 4 insertions(+), 6 deletions(-)

diff --git a/dist/Devel-PPPort/HACKERS b/dist/Devel-PPPort/HACKERS
index 4f354043aa..2e035dfc7e 100644
--- a/dist/Devel-PPPort/HACKERS
+++ b/dist/Devel-PPPort/HACKERS
@@ -287,9 +287,8 @@ That's it.
 =head2 Submitting Patches
 
 If you've added some functionality to C<Devel::PPPort>, please
-consider submitting a patch with your work to GitHub here:
-L<https://github.com/mhx/Devel-PPPort/issues/>, or by sending a
-Pull Request.
+consider submitting a patch with your work to P5P by sending a mail
+to L<perlbug@perl.org>.
 
 When submitting patches, please only add the relevant changes
 and don't include the differences of the generated files. You
diff --git a/dist/Devel-PPPort/PPPort_pm.PL b/dist/Devel-PPPort/PPPort_pm.PL
index 15cfe63405..78d35e58af 100644
--- a/dist/Devel-PPPort/PPPort_pm.PL
+++ b/dist/Devel-PPPort/PPPort_pm.PL
@@ -492,8 +492,7 @@ __UNSUPPORTED_API__
 =head1 BUGS
 
 If you find any bugs, C<Devel::PPPort> doesn't seem to build on your
-system, or any of its tests fail, please file an issue here:
-L<https://github.com/mhx/Devel-PPPort/issues/>
+system, or any of its tests fail, please send a bug report to L<perlbug@perl.org>.
 
 =head1 AUTHORS
 
diff --git a/dist/Devel-PPPort/parts/inc/ppphdoc b/dist/Devel-PPPort/parts/inc/ppphdoc
index 2b4d857470..6382ab1ad4 100644
--- a/dist/Devel-PPPort/parts/inc/ppphdoc
+++ b/dist/Devel-PPPort/parts/inc/ppphdoc
@@ -297,7 +297,7 @@ before sending a bug report.
 
 If F<ppport.h> was generated using the latest version of
 C<Devel::PPPort> and is causing failure of this module, please
-file a bug report here: L<https://github.com/mhx/Devel-PPPort/issues/>
+send a bug report to L<perlbug@perl.org>.
 
 Please include the following information:
 
-- 
2.14.2

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 26, 2018

From @dur-randir

The first patch in series seems to be missing, resending it.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 26, 2018

From @dur-randir

0001-Update-RT-path-for-Devel-PPPort.patch
From e995f577bb800e5336d1fc13bbae9256bd7ac49f Mon Sep 17 00:00:00 2001
From: Sergey Aleynikov <sergey.aleynikov@gmail.com>
Date: Mon, 26 Mar 2018 23:26:47 +0300
Subject: [PATCH 1/2] Update RT path for Devel::PPPort

---
 dist/Devel-PPPort/Makefile.PL | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/dist/Devel-PPPort/Makefile.PL b/dist/Devel-PPPort/Makefile.PL
index 25e352e641..117f9d107a 100644
--- a/dist/Devel-PPPort/Makefile.PL
+++ b/dist/Devel-PPPort/Makefile.PL
@@ -40,12 +40,12 @@ WriteMakefile(
     },
     resources => {
       bugtracker => {
-        web => 'https://github.com/mhx/Devel-PPPort/issues/',
+        web => 'https://rt.perl.org/rt3/',
       },
       repository => {
         type => 'git',
-        url  => 'git://github.com/mhx/Devel-PPPort.git',
-        web  => 'https://github.com/mhx/Devel-PPPort/',
+        url  => 'git://perl5.git.perl.org/perl.git',
+        web  => 'https://perl5.git.perl.org/perl.git',
       },
     },
   },
-- 
2.14.2

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 27, 2018

From @khwilliamson

On 03/26/2018 02​:48 PM, Sergey Aleynikov via RT wrote​:

The first patch in series seems to be missing, resending it.

---
via perlbug​: queue​: perl5 status​: open
https://rt-archive.perl.org/perl5/Ticket/Display.html?id=132906

Thanks, applied as 5936215

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 28, 2018

From @dur-randir

On Tue, 27 Mar 2018 12​:06​:06 -0700, public@​khwilliamson.com wrote​:

Thanks, applied as 5936215

Thanks, but there're still some links to github, which were updated by 0002-Update-links-in-Devel-PPPort-documentation.patch. Is it postponed until after the freeze ends?

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 29, 2018

From @khwilliamson

On 03/28/2018 03​:02 PM, Sergey Aleynikov via RT wrote​:

On Tue, 27 Mar 2018 12​:06​:06 -0700, public@​khwilliamson.com wrote​:

Thanks, applied as 5936215

Thanks, but there're still some links to github, which were updated by 0002-Update-links-in-Devel-PPPort-documentation.patch. Is it postponed until after the freeze ends?

An oversight. The full freeze isn't until April 20th

Thanks, pushed as c601e8c

Anything else that needs to be done for this ticket?

---
via perlbug​: queue​: perl5 status​: open
https://rt-archive.perl.org/perl5/Ticket/Display.html?id=132906

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 29, 2018

From @dur-randir

On Wed, 28 Mar 2018 17​:34​:58 -0700, public@​khwilliamson.com wrote​:

Anything else that needs to be done for this ticket?

Release a fresh D​::P version to CPAN?) Other than that, I see nothing pending here. Github -> RT transition for tickets can be done separately.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 29, 2018

From @khwilliamson

OP says this is ok to close
--
Karl Williamson

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Mar 29, 2018

@khwilliamson - Status changed from 'open' to 'pending release'

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Jun 23, 2018

From @khwilliamson

Thank you for filing this report. You have helped make Perl better.

With the release yesterday of Perl 5.28.0, this and 185 other issues have been
resolved.

Perl 5.28.0 may be downloaded via​:
https://metacpan.org/release/XSAWYERX/perl-5.28.0

If you find that the problem persists, feel free to reopen this ticket.

@p5pRT p5pRT closed this as completed Jun 23, 2018
@p5pRT
Copy link
Author

@p5pRT p5pRT commented Jun 23, 2018

@khwilliamson - Status changed from 'pending release' to 'resolved'

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

1 participant