Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

t/comp/require.t fails - sometimes #2219

Closed
p5pRT opened this issue Jul 16, 2000 · 3 comments
Closed

t/comp/require.t fails - sometimes #2219

p5pRT opened this issue Jul 16, 2000 · 3 comments

Comments

@p5pRT
Copy link

@p5pRT p5pRT commented Jul 16, 2000

Migrated from rt.perl.org#3530 (status was 'resolved')

Searchable as RT3530$

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Jul 16, 2000

From lvirden@cas.org

Created by lvirden@cas.org

This is a bug report for perl from lvirden@​cas.org,
generated with the help of perlbug 1.29 running under perl v5.6.0.

-----------------------------------------------------------------
When running a make test after patching perl 5.6.0 with the latest rsync
of patches, I am finding the following behavior​:
.
.
comp/require.........FAILED at test 23
.
.
Failed 1 test script out of 244, 99.59% okay.
  ### Since not all tests were successful, you may want to run some
  ### of them individually and examine any diagnostic messages they
  ### produce. See the INSTALL document's section on "make test".
  ### If you are testing the compiler, then ignore this message
  ### and run
  ### ./perl harness
  ### in the directory ./t.
  ###
  ### Since most tests were successful, you have a good chance to
  ### get information with better granularity by running
  ### ./perl harness
  ### in directory ./t.
u=2.63 s=0.79 cu=161.38 cs=36.25 scripts=244 tests=12453
make​: *** [test] Error 1

Now, I do
$ ./perl t/comp/require.t
1..23
ok 1
ok 2
ok 3
ok 4
ok 5
ok 6
ok 7
ok 8
ok 9
ok 10
ok 11
ok 12
ok 13
ok 14
ok 15
ok 16
ok 17
ok 18
ok 19
ok 20
ok 21
ok 22

When I cd to t and do the ./perl harness I get the same thing as the
make test.

P.S. in t/README, the last of the file says to mail new tests to
larry@​wall.org; shouldn't the new tests be going to the same place bug and
enhancement requests go?

Perl Info

Flags:
    category=core
    severity=medium

Site configuration information for perl v5.6.0:

Configured by lwv26 at Mon Jul  3 07:54:50 EDT 2000.

Summary of my perl5 (revision 5.0 version 6 subversion 0) configuration:
  Platform:
    osname=solaris, osvers=2.6, archname=sun4-solaris
    uname='sunos lwv26awu 5.6 generic_105181-20 sun4u sparc sunw,ultra-5_10 '
    config_args=''
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
    useperlio=undef d_sfio=undef uselargefiles=define 
    use64bitint=undef use64bitall=undef uselongdouble=undef usesocks=undef
  Compiler:
    cc='cc', optimize='-g', gccversion=
    cppflags='-DDEBUGGING -I/projects/gnu/sparc-sun-solaris2.6/include -I/vol/lwv26ldatae/include -I/vol/SUNWspro/SC5.0/include -I/usr/ccs/include'
    ccflags ='-DDEBUGGING -I/projects/gnu/sparc-sun-solaris2.6/include -I/vol/lwv26ldatae/include -I/vol/SUNWspro/SC5.0/include -I/usr/ccs/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
    stdchar='unsigned char', d_stdstdio=define, usevfork=false
    intsize=4, longsize=4, ptrsize=4, doublesize=8
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, usemymalloc=y, prototype=define
  Linker and Libraries:
    ld='cc', ldflags ='-R/projects/gnu/sparc-sun-solaris2.6/lib:/vol/lwv26ldatae/lib:/vol/SUNWspro/SC5.0/lib:/usr/ccs/lib -L/projects/gnu/sparc-sun-solaris2.6/lib -L/vol/lwv26ldatae/lib -L/vol/SUNWspro/SC5.0/lib -L/usr/ccs/lib '
    libpth=/projects/gnu/sparc-sun-solaris2.6/lib /vol/lwv26ldatae/lib /vol/SUNWspro/SC5.0/lib /usr/lib /usr/ccs/lib
    libs=-lsocket -lnsl -lgdbm -ldb -ldl -lm -lc -lcrypt -lsec
    libc=/lib/libc.so, so=so, useshrplib=false, libperl=libperl.a
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='-KPIC', lddlflags='-G -R/projects/gnu/sparc-sun-solaris2.6/lib:/vol/lwv26ldatae/lib:/vol/SUNWspro/SC5.0/lib:/usr/ccs/lib -L/projects/gnu/sparc-sun-solaris2.6/lib -L/vol/lwv26ldatae/lib -L/vol/SUNWspro/SC5.0/lib -L/usr/ccs/lib'

Locally applied patches:
    


@INC for perl v5.6.0:
    /home/lwv26/lib/perl5/
    /projects/sprs_lwv/lib/perl5/
    /vol/lwv26ldatae//lib/perl5/5.6.0/sun4-solaris
    /vol/lwv26ldatae//lib/perl5/5.6.0
    /vol/lwv26ldatae//lib/perl5/site_perl/5.6.0/sun4-solaris
    /vol/lwv26ldatae//lib/perl5/site_perl/5.6.0
    /vol/lwv26ldatae//lib/perl5/site_perl
    .


Environment for perl v5.6.0:
    HOME=/home/lwv26
    LANG=C
    LANGUAGE (unset)
    LD_LIBRARY_PATH=/lprod/cas/lib:/usr/dt/lib:/usr/openwin/lib:/usr/lib
    LOGDIR (unset)
    PATH=/vol/SUNWspro/bin:/ldatae/bin:/projects/sprs_lwv/sol26/bin:/projects/sprs_lwv/sol26/bin/mime:/projects/sprs_lwv/sol2/bin:/projects/sprs_lwv/bin:/projects/sprs_lwv/bin/mime:/home/lwv26/bin/D.news:/usr/perl5/bin:/projects/gnu/sparc-sun-solaris2.6/bin:/usr/tcl83/bin:/usr/tcl82/sun4/bin:/usr/tcl82/bin:/projects/xopsrc/sun4/bin:/projects/xopsrc/bin:/usr/atria/bin:/projects/intranet/bin:/projects/clearcase/bin:/vol/tclsrcsol/TclPro1.3/solaris-sparc/bin:/ldata2/teTeX/bin/sparc-sun-solaris2.6:/vol/adobe/Acrobat3/bin:/ldata/bin:/home/lwv26/bin/D.aws:/home/lwv26/bin/sol2:/home/lwv26/bin/D.frontend:/home/lwv26/bin/D.ksh:/cas/test/bin/sun4:/projects/sprs_lwv/bin/sol2:/usr/java1.2/bin:/home/lwv26/bin/sun4:/lprod/cas/bin:/usr/local/bin:/usr/dt/bin:/usr/openwin/bin:/bin:/cas/bin/sun4:/cas/abin/sun4:/cas/X11/sun4/bin:/usr/ccs/bin:/lprod/bin:/usr/sbin:/usr/ucb:/cas/tools/bin/sun4:/cas/X11/sun4/tools/bin:/home/lwv26/bin:/cas/tools/pdbin/sun4:/home/lwv26/bin/D.mistypes:/home/lwv26/bin!
/D.toys:/home/lwv26/bin/D.tools:/projects/npd/npdweb/bin-sol2:/vol/tclsrcsol/TclPro/solaris-sparc/bin
    PERL5LIB=/home/lwv26/lib/perl5/:/projects/sprs_lwv/lib/perl5/:
    PERLDOC=-t
    PERLLIB=/home/lwv26/lib/perl:/projects/sprs_lwv/lib/perl:
    PERL_BADLANG (unset)
    SHELL=/bin/ksh



@p5pRT
Copy link
Author

@p5pRT p5pRT commented Jan 8, 2007

From @rgs

Closing this old, not reproducible bug.

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Jan 8, 2007

@rgs - Status changed from 'open' to 'resolved'

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant