Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Not OK: perl v5.7.0 +DEVEL7001 on i86pc-solaris-64all 2.8 (UNINSTALLED) #2567

Closed
p5pRT opened this issue Sep 2, 2000 · 3 comments
Closed

Not OK: perl v5.7.0 +DEVEL7001 on i86pc-solaris-64all 2.8 (UNINSTALLED) #2567

p5pRT opened this issue Sep 2, 2000 · 3 comments

Comments

@p5pRT
Copy link

@p5pRT p5pRT commented Sep 2, 2000

Migrated from rt.perl.org#4204 (status was 'resolved')

Searchable as RT4204$

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Sep 2, 2000

From lupe@lupe-christoph.de

This is a build failure report for perl from lupe@​lupe-christoph.de,
generated with the help of perlbug 1.32 running under perl v5.7.0.


Using Sun's Forte 6.0 C 5.1 with patches 109487-01 and 109492-01.

Modulus tests fail​:
op/64bitint..........FAILED at test 25
op/arith.............FAILED at test 9

In op/arith.t, tests 9..12 fail when I run it manually.

The failures go away when I compile pp.c with '-O'. This
looks like Sun's BugID 4170068 redivivus.



Flags​:
  category=install
  severity=none


This perlbug was built using Perl v5.7.0 - Sat Sep 2 15​:04​:50 MEST 2000
It is being executed now by Perl v5.7.0 - Wed Aug 2 16​:01​:39 MEST 2000.

Site configuration information for perl v5.7.0​:

Configured by lupe at Wed Aug 2 16​:01​:39 MEST 2000.

Summary of my perl5 (revision 5.0 version 7 subversion 0) configuration​:
  Platform​:
  osname=solaris, osvers=2.8, archname=i86pc-solaris-64all
  uname='sunos alanya.lupe-christoph.de 5.8 generic_108529-01 i86pc i386 i86pc '
  config_args='-Dusedevel'
  hint=recommended, useposix=true, d_sigaction=define
  usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
  useperlio=undef d_sfio=undef uselargefiles=define usesocks=undef
  use64bitint=define use64bitall=define uselongdouble=undef
  Compiler​:
  cc='cc', ccflags ='-I/opt/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64', optimize='-O', cppflags='-I/opt/local/include'
  ccversion='Sun WorkShop 6 2000/04/07 C 5.1', gccversion='', gccosandvers=''
  intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=12345678
  d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
  ivtype='long long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
  alignbytes=4, usemymalloc=y, prototype=define
  Linker and Libraries​:
  ld='cc', ldflags ='-L/opt/local/i386/lib -L/opt/SUNWspro/WS6/lib -R/opt/local/i386/lib​:/opt/SUNWspro/WS6/lib '
  libpth=/opt/local/i386/lib /opt/SUNWspro/WS6/lib /usr/lib /usr/ccs/lib
  libs=-lsocket -lnsl -lgdbm -ldb -ldl -lm -lc
  libc=/lib/libc.so, so=so, useshrplib=false, libperl=libperl.a
  Dynamic Linking​:
  dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
  cccdlflags='-KPIC', lddlflags='-G -L/opt/local/i386/lib -L/opt/SUNWspro/WS6/lib -R/opt/local/i386/lib​:/opt/SUNWspro/WS6/lib'

Locally applied patches​:
  DEVEL7001


@​INC for perl v5.7.0​:
  lib
  /sw/tmp/bleadperl@​7001/lib/5.7.0/i86pc-solaris-64all
  /sw/tmp/bleadperl@​7001/lib/5.7.0
  /sw/tmp/bleadperl@​7001/lib/site_perl/5.7.0/i86pc-solaris-64all
  /sw/tmp/bleadperl@​7001/lib/site_perl/5.7.0
  /sw/tmp/bleadperl@​7001/lib/site_perl
  .


Environment for perl v5.7.0​:
  HOME=/home/lupe
  LANG=en_US
  LANGUAGE (unset)
  LD_LIBRARY_PATH=/opt/local/i386/lib​:/usr/dt/lib​:/usr/openwin/lib
  LOGDIR (unset)
  PATH=.​:/home/lupe/scripts​:/home/lupe/i386/bin​:/opt/local/scripts​:/opt/local/i386/sbin​:/opt/local/i386/bin​:/opt/SUNWspro/bin​:/usr/ccs/bin​:/opt/local/kvm-5.x-i86pc​:/etc​:/sbin​:/usr/sbin​:/usr/dt/bin​:/usr/openwin/bin​:/opt/local/i386/x11bin​:/usr/bin
  PERL_BADLANG (unset)
  SHELL=/bin/tcsh

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Sep 3, 2000

From @AlanBurlison

Lupe Christoph wrote​:

This is a build failure report for perl from lupe@​lupe-christoph.de,
generated with the help of perlbug 1.32 running under perl v5.7.0.

-----------------------------------------------------------------
Using Sun's Forte 6.0 C 5.1 with patches 109487-01 and 109492-01.

Modulus tests fail​:
op/64bitint..........FAILED at test 25
op/arith.............FAILED at test 9

In op/arith.t, tests 9..12 fail when I run it manually.

The failures go away when I compile pp.c with '-O'. This
looks like Sun's BugID 4170068 redivivus.
-----------------------------------------------------------------

If you can provide a simple test case I'll submit a bug.

Alan Burlison

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Nov 28, 2003

From The RT System itself

Solaris C compiler bug.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant