Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ppm on NT, no installation possible! #825

Closed
p5pRT opened this issue Nov 7, 1999 · 2 comments
Closed

ppm on NT, no installation possible! #825

p5pRT opened this issue Nov 7, 1999 · 2 comments

Comments

@p5pRT
Copy link
Collaborator

@p5pRT p5pRT commented Nov 7, 1999

Migrated from rt.perl.org#1753 (status was 'resolved')

Searchable as RT1753$

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Nov 7, 1999

From heitz@heitz.de

Created by onestone@excite.com

I am trying to install packages on NT 4.0 SP5, using PDK 1.2.4 and
ActivePerl521. The symptom looks as if perl wod try to open $PACKETNAME/.packlist/. as a file! here is the output from ppm​:

PPM> install Image-Size Image-Magick
Install package 'Image-Size?' (y/N)​: y
Retrieving package 'Image-Size'...
Installing \\DIBBE\Perl\html\lib\Image\Size.html
Installing C​:\Perl\lib\auto\Image\Size\autosplit.ix
Installing C​:\Perl\lib\auto\Image\Size\gifsize.al
Installing C​:\Perl\lib\auto\Image\Size\jpegsize.al
Installing C​:\Perl\lib\auto\Image\Size\pngsize.al
Installing C​:\Perl\lib\auto\Image\Size\ppmsize.al
Installing C​:\Perl\lib\auto\Image\Size\tiffsize.al
Installing C​:\Perl\lib\auto\Image\Size\xbmsize.al
Installing C​:\Perl\lib\auto\Image\Size\xpmsize.al
Installing C​:\Perl\lib\Image\Size.pm
Installing C​:\Perl\bin\imgsize
Installing C​:\Perl\bin\imgsize.bat
Writing C​:\Perl\lib\auto\Image\Size\.packlist\.
Error installing package 'Image-Size'​: Can't open file C​:\Perl\lib\auto\Image\Si
ze\.packlist\.​: Permission denied at C​:/Perl/lib/ExtUtils/Install.pm line 144

Install package 'Image-Magick?' (y/N)​: y
Retrieving package 'Image-Magick'...
Installing C​:\Perl\site\lib\auto\Image\Magick\Magick.bs
Installing C​:\Perl\site\lib\auto\Image\Magick\Magick.dll
Installing C​:\Perl\site\lib\auto\Image\Magick\Magick.exp
Installing C​:\Perl\site\lib\auto\Image\Magick\Magick.lib
Installing C​:\Perl\bin\FPXLIB.DLL
Installing C​:\Perl\bin\IMagick.dll
Installing C​:\Perl\bin\JPEGLIB.DLL
Installing C​:\Perl\bin\X11.dll
Installing C​:\Perl\bin\Xext.dll
Installing \\DIBBE\Perl\html\lib\site\Image\Magick.html
Installing C​:\Perl\lib\auto\Image\Magick\autosplit.ix
Installing C​:\Perl\lib\Image\Magick.pm
Writing C​:\Perl\lib\auto\Image\Magick\.packlist\.
Error installing package 'Image-Magick'​: Can't open file C​:\Perl\lib\auto\Image\Magick\.packlist\.​: Permission denied at C​:/Perl/lib/ExtUtils/Install.pm line 144

PPM> quit

it's not as bad as it looks, cause on my linux box everything works fine!-) Only
thing to worry​: I did pay some bux for the activestate version while linux is
free and betterX!-(

Perl Info


Site configuration information for perl 5.00503:

Summary of my perl5 (5.0 patchlevel 5 subversion 03) configuration:
  Platform:
    osname=MSWin32, osvers=4.0, archname=MSWin32-x86-object
    uname=''
    hint=recommended, useposix=true, d_sigaction=undef
    usethreads=undef useperlio=undef d_sfio=undef
  Compiler:
    cc='cl.exe', optimize='-Od -MD -DNDEBUG -TP -GX', gccversion=
    cppflags='-DWIN32'
    ccflags ='-Od -MD -DNDEBUG -TP -GX -DWIN32 -D_CONSOLE -DNO_STRICT  -DHAVE_DES_FCRYPT -DPERL_OBJECT'
    stdchar='char', d_stdstdio=define, usevfork=false
    intsize=4, longsize=4, ptrsize=4, doublesize=8
    d_longlong=undef, longlongsize=8, d_longdbl=define, longdblsize=10
    alignbytes=8, usemymalloc=n, prototype=define
  Linker and Libraries:
    ld='link', ldflags ='-nologo -nodefaultlib -release -libpath:"\\DIBBE\Perl\lib\CORE" -machine:x86'
    libpth="\\DIBBE\Perl\lib\core" "d:\objy51\lib" "e:\msdev\lib" "e:\msdev\mfc\lib" "d:\programme\devstudio\vc\lib" "d:\programme\devstudio\vc\mfc\lib" "d:\objy51\lib" 
    libs= oldnames.lib kernel32.lib user32.lib gdi32.lib  winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib  oleaut32.lib netapi32.lib uuid.lib wsock32.lib mpr.lib winmm.lib  version.lib odbc32.lib odbccp32.lib PerlCRT.lib
    libc=\\DIBBE\Perl\lib\CORE\PerlCRT.lib, so=dll, useshrplib=yes, libperl=perlcore.lib
  Dynamic Linking:
    dlsrc=dl_win32.xs, dlext=dll, d_dlsymun=undef, ccdlflags=' '
    cccdlflags=' ', lddlflags='-dll -nologo -nodefaultlib -release -libpath:"\\DIBBE\Perl\lib\CORE" -machine:x86'

Locally applied patches:
    ACTIVEPERL_LOCAL_PATCHES_ENTRY


@INC for perl 5.00503:
    C:/Perl/lib
    C:/Perl/site/lib
    .


Environment for perl 5.00503:
    HOME (unset)
    LANG (unset)
    LANGUAGE (unset)
    LD_LIBRARY_PATH (unset)
    LOGDIR (unset)
    PATH=C:\Perl\bin;C:\WINNT\system32;c:\usr\local\bin;d:\programme\Microsoft Visual Studio\Common\MSDev98\bin;c:\usr\local\lib\vim;C:\WINDOWS;C:\WINDOWS\COMMAND;C:\THINKPAD;C:\CARDWORK;
    PERL_BADLANG (unset)
    SHELL (unset)


Site configuration information for perl 5.00503:

Configured by root at Thu Jul 22 21:18:56 GMT 1999.

Summary of my perl5 (5.0 patchlevel 5 subversion 3) configuration:
  Platform:
    osname=linux, osvers=2.2.10, archname=i586-linux
    uname='linux fatou 2.2.10 #2 smp thu jul 15 15:03:02 mest 1999 i686 unknown '
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef useperlio=undef d_sfio=undef
  Compiler:
    cc='cc', optimize='-O2 -pipe', gccversion=egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)
    cppflags='-Dbool=char -DHAS_BOOL -I/usr/local/include'
    ccflags ='-Dbool=char -DHAS_BOOL -I/usr/local/include'
    stdchar='char', d_stdstdio=undef, usevfork=false
    intsize=4, longsize=4, ptrsize=4, doublesize=8
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    alignbytes=4, usemymalloc=n, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib
    libs=-lnsl -lndbm -lgdbm -ldb -ldl -lm -lc -lposix -lcrypt
    libc=, so=so, useshrplib=false, libperl=libperl.a
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-rdynamic'
    cccdlflags='-fpic', lddlflags='-shared -L/usr/local/lib'

Locally applied patches:
    


@INC for perl 5.00503:
    /usr/lib/perl5/5.00503/i586-linux
    /usr/lib/perl5/5.00503
    /usr/lib/perl5/site_perl/5.005/i586-linux
    /usr/lib/perl5/site_perl/5.005
    .


Environment for perl 5.00503:
    HOME=/home/heitz
    LANG=german
    LANGUAGE (unset)
    LC_CTYPE=de_DE
    LD_LIBRARY_PATH=/usr/local/lib:/usr/X11R6.1/lib:/usr/ucblib:/usr/openwin/lib:/usr/lib:/opt/lib:/lib:/usr/dt/lib:/opt/netscape
    LOGDIR (unset)
    PATH=/bin:/usr/sbin:/usr/bin:/usr/ucb:/usr/X11/bin:/opt/netscape:/sbin:/usr/dt/bin:/usr/openwin/bin:/usr/sbin:/usr/local/bin:/usr/ccs/bin:/usr/local/sbin:/opt/kde/bin:/usr/local/scripts:/etc:/home/heitz/bin:.:/opt/bin:/usr/local/samba/bin:/awd01/EVS/maketools/solaris:/usr/ucblib
    PERL_BADLANG (unset)
    SHELL=/bin/tcsh

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Nov 7, 1999

From @jandubois

On Sun, 7 Nov 1999 23​:28​:11 +0100, heitz@​heitz.de wrote​:

This is a bug report for perl from onestone@​excite.com,
generated with the help of perlbug 1.26 running under perl 5.00503.

Please don't send ActivePerl related bug reports to perl5-porters! The
Readme (under "Getting Started" in the online documentation) contains a
link to the ActivePerl bug database​:

  http​://bugs.activestate.com/ap.bugs

You can also submit bug reports via email to

  mailto​:ap.bugs@​activestate.com

Thanks!

-----------------------------------------------------------------
[Please enter your report here]
I am trying to install packages on NT 4.0 SP5, using PDK 1.2.4 and
ActivePerl521. The symptom looks as if perl wod try to open $PACKETNAME/.packlist/. as a file! here is the output from ppm​:

[...]

Writing C​:\Perl\lib\auto\Image\Size\.packlist\.
Error installing package 'Image-Size'​: Can't open file C​:\Perl\lib\auto\Image\Si
ze\.packlist\.​: Permission denied at C​:/Perl/lib/ExtUtils/Install.pm line 144

It does indeed look as if '\\.' somehow got appended to the .packlist
filename. It doesn't happen for me (with ActivePerl 522). I just
reinstalled 521 to check if that one contained a botched PPM.pm, but it
also worked fine. I've looked at the source (/perl/site/lib/PPM.pm) and
the relevant lines would be​:

| my $packlist = MM->catdir("$Config{installsitearch}/auto", split(/-/, $current_package{'NAME'}), ".packlist");
...
| if ($root ne $inst_root) {
| if ($packlist =~ /\\lib\\(.*)/) {
| $packlist = "$root\\lib\\$1";
| }
...
| ExtUtils​::Install​::install({
| "read" => $packlist, "write" => $packlist,

I don't see how the suffix can get appended (yes, I also looked at
/perl/lib/ExtUtils/Install.pm). But then again, the error doesn't happen
on my system. Did you modify any of the files mentioned above?

The one thing I cannot test here at home is the network installer of the
PDK (I cannot create share names here). Does the error also happen on a
machine that doesn't have the PDK network installer installed?

Anyways, the modules seemed to get installed ok; only the .packlist didn't
get written. This makes it impossible to uninstall the packages via PPM
but the modules should be normally useable.

PPM> quit

it's not as bad as it looks, cause on my linux box everything works fine!-) Only
thing to worry​: I did pay some bux for the activestate version while linux is
free and betterX!-(

Well, you can always download the ActiveState version for free from the
web. I assume you only paid for the PDK, but then your Linux version
didn't include that one for free either.

-Jan

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.