Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Language plugins should be able to be API version aware. #165

Closed
plicease opened this issue Aug 1, 2019 · 0 comments

Comments

@plicease
Copy link
Member

commented Aug 1, 2019

I think this should only be an issue for the type map, which is dependent on the type parser. It probably would be a good idea, however to feed the api version into the mangler too somehow in case there are changes there for api = 2? The latter is tricky because it just takes a list of libs atm, so I think passing in something new could break the C++ plugin, and this may require a new methods for api > 0.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.