Permalink
Browse files

Removed Class::Data::Accessor and DBIx::Class::AccessorGrouped and

replaced with Class::Accessor::Grouped.

component_class type accessors now just inherited and so no longer 
automatcally require classes when set (noted in changes)

Added auto_install to Makefile.PL
  • Loading branch information...
ashb committed Nov 18, 2006
1 parent 665256a commit 3e11041012dc26df94860efefde4340bf927f2af
View
@@ -16,6 +16,12 @@ Revision history for DBIx::Class
- columns_info_for is deprecated, and no longer runs automatically.
You can make it work like before via
__PACKAGE__->column_info_from_storage(1) for now
+ - Replaced DBIx::Class::AccessorGroup and Class::Data::Accessor with
+ Class::Accessor::Grouped. Only user noticible change is to
+ table_class on ResultSourceProxy::Table (i.e. table objects in
+ schemas) and, resultset_class and result_class in ResultSource.
+ These accessors no longer automatically require the classes when
+ set.
0.07003 2006-XX-XX XX:XX:XX
- Tweaks to resultset to allow inflate_result to return an array
View
@@ -25,6 +25,7 @@
\.tmp$
\.old$
\.bak$
+\..*?\.sw[po]$
\#$
\b\.#
View
@@ -11,11 +11,11 @@ requires 'SQL::Abstract' => 1.20;
requires 'SQL::Abstract::Limit' => 0.101;
requires 'Class::C3' => 0.13;
requires 'Storable' => 0;
-requires 'Class::Data::Accessor' => 0.01;
requires 'Carp::Clan' => 0;
requires 'DBI' => 1.40;
requires 'Module::Find' => 0;
requires 'Class::Inspector' => 0;
+requires 'Class::Accessor::Grouped' => 0;
# Perl 5.8.0 doesn't have utf8::is_utf8()
requires 'Encode' => 0 if ($] <= 5.008000);
@@ -26,4 +26,6 @@ install_script 'script/dbicadmin';
tests "t/*.t t/*/*.t";
+auto_install;
+
WriteAll;
View
@@ -4,9 +4,14 @@ use strict;
use warnings;
use vars qw($VERSION);
-use base qw/DBIx::Class::Componentised Class::Data::Accessor/;
+use base qw/DBIx::Class::Componentised Class::Accessor::Grouped/;
+
+sub mk_classdata {
+ my $self = shift;
+ $self->mk_group_accessors('inherited', $_[0]);
+ $self->set_inherited(@_) if @_ > 1;
+}
-sub mk_classdata { shift->mk_classaccessor(@_); }
sub component_base_class { 'DBIx::Class' }
# Always remember to do all digits for the version even if they're 0
Oops, something went wrong.

0 comments on commit 3e11041

Please sign in to comment.