Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 59 lines (48 sloc) 1.938 kb
b3d5b31 first version of Makefile.PL
Alexis Sukrieh authored
1 use ExtUtils::MakeMaker;
2
1404a83 @cpanservice Upgrade Makefile.PL
cpanservice authored
3 WriteMakefile1(
b3c8b5f Makefile.PL upgrade (add a clean rule)
Alexis Sukrieh authored
4 NAME => 'Dancer',
5 ABSTRACT => "A minimal-effort oriented web application framework",
6 LICENSE => 'perl',
7 VERSION_FROM => 'lib/Dancer.pm',
8 EXE_FILES => ['script/dancer'],
9
1404a83 @cpanservice Upgrade Makefile.PL
cpanservice authored
10 META_MERGE => {
11 resources => {
12 repository => 'http://github.com/sukria/Dancer',
13 },
14 },
15
b3c8b5f Makefile.PL upgrade (add a clean rule)
Alexis Sukrieh authored
16 BUILD_REQUIRES => {
17 'Test::More' => '0',
18 },
19
b3d5b31 first version of Makefile.PL
Alexis Sukrieh authored
20 PREREQ_PM => {
820d89a REAMDE update + Makefile.PL deps update
Alexis Sukrieh authored
21 # non-core
11a4378 now depends on HTTP::Server::Simple::PSGI
Alexis Sukrieh authored
22 'HTTP::Body' => '0',
5f02e58 HTTP::Server::Simple::PSGI dependency update: 0.11
Alexis Sukrieh authored
23 'HTTP::Server::Simple::PSGI' => '0.11',
11a4378 now depends on HTTP::Server::Simple::PSGI
Alexis Sukrieh authored
24 'Exception::Class' => '0',
820d89a REAMDE update + Makefile.PL deps update
Alexis Sukrieh authored
25
26 # core
a01397a move to File::MimeInfo::Simple and provide a default mime_types table (t...
Alexis Sukrieh authored
27 'File::Basename' => '0',
28 'File::Spec' => '0',
b3d5b31 first version of Makefile.PL
Alexis Sukrieh authored
29 },
b3c8b5f Makefile.PL upgrade (add a clean rule)
Alexis Sukrieh authored
30
31 test => {TESTS => join( ' ', (glob( 't/*.t'), glob('t/*/*.t')))},
32 clean => {FILES => "t/lib/sessions/*.yml logs/*.log t/*/logs/*" }
33
b3d5b31 first version of Makefile.PL
Alexis Sukrieh authored
34 );
1404a83 @cpanservice Upgrade Makefile.PL
cpanservice authored
35
36 sub WriteMakefile1 { #Written by Alexandr Ciornii, version 0.21. Added by eumm-upgrade.
37 my %params=@_;
38 my $eumm_version=$ExtUtils::MakeMaker::VERSION;
39 $eumm_version=eval $eumm_version;
40 die "EXTRA_META is deprecated" if exists $params{EXTRA_META};
41 die "License not specified" if not exists $params{LICENSE};
42 if ($params{BUILD_REQUIRES} and $eumm_version < 6.5503) {
43 #EUMM 6.5502 has problems with BUILD_REQUIRES
44 $params{PREREQ_PM}={ %{$params{PREREQ_PM} || {}} , %{$params{BUILD_REQUIRES}} };
45 delete $params{BUILD_REQUIRES};
46 }
47 delete $params{CONFIGURE_REQUIRES} if $eumm_version < 6.52;
48 delete $params{MIN_PERL_VERSION} if $eumm_version < 6.48;
49 delete $params{META_MERGE} if $eumm_version < 6.46;
50 delete $params{META_ADD} if $eumm_version < 6.46;
51 delete $params{LICENSE} if $eumm_version < 6.31;
52 delete $params{AUTHOR} if $] < 5.005;
53 delete $params{ABSTRACT_FROM} if $] < 5.005;
54 delete $params{BINARY_LOCATION} if $] < 5.005;
55
56 WriteMakefile(%params);
57 }
58
Something went wrong with that request. Please try again.