SDL_perl doesn't pass tests in t/ #1

Closed
kthakore opened this Issue Aug 1, 2009 · 3 comments

Comments

Projects
None yet
2 participants
Owner

kthakore commented Aug 1, 2009

Since these test are 4 years old. We need to go through them and see which are relevant and pass the test as necessary.

Owner

kthakore commented Aug 1, 2009

most errors seems to be cause by build system. Need to change that

perl Build test
t/apppm............ok
t/cdrompm..........ok
t/colorpm..........ok
t/cursorpm.........ok
t/eventpm..........ok
t/fontpm...........ok
t/mixerpm..........dubious
Test returned status 0 (wstat 140, 0x8c)
DIED. FAILED test 3
Failed 1/3 tests, 66.67% okay
t/mpegpm...........ok
t/musicpm..........ok
t/opengl...........ok
t/palettepm........ok
t/rectpm...........ok
t/sdlpm............ok
t/soundpm..........ok
t/surfacepm........ok
t/timerpm..........dubious
Test returned status 0 (wstat 140, 0x8c)
DIED. FAILED tests 3-4
Failed 2/4 tests, 50.00% okay
t/toolfontpm.......ok
t/toolgraphicpm....ok
t/ttfontpm.........ok
t/videopm..........ok

Failed Test Stat Wstat Total Fail List of Failed

t/mixerpm.t 0 140 3 2 3
t/timerpm.t 0 140 4 4 3-4
Failed 2/20 test scripts. 3/75 subtests failed.
Files=20, Tests=75, 1 wallclock secs ( 0.77 cusr + 0.23 csys = 1.01 CPU)
Failed 2/20 test programs. 3/75 subtests failed.
perl t/mixerpm.t
1..3
ok 1 - use SDL::Mixer;
ok 2 - SDL::Mixer->can(...)
Bad system call (core dumped)

FreeBSD 7.2.

Owner

kthakore commented Aug 2, 2009

this build system needs to be rewriten ...

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment