Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Linking wrong libSDL #242

Open
jtpalmer opened this Issue · 0 comments

1 participant

@jtpalmer
Owner

This is probably a darwin issue, but I haven't confirmed that yet.

My SDLPerl is linking against the libSDL in my ~/.cpanm directory:

$ otool -L /Users/jtpalmer/.perlbrew/perls/perl-5.16.0/bin/SDLPerl
/Users/jtpalmer/.perlbrew/perls/perl-5.16.0/bin/SDLPerl:
        /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)
        /usr/lib/libutil.dylib (compatibility version 1.0.0, current version 1.0.0)
        /Users/jtpalmer/.cpanm/work/1350148134.67588/Alien-SDL-1.438/sharedir/1.438_cdddb72e/lib/libSDL-1.2.0.dylib (compatibility version 12.0.0, current version 12.4.0)
        /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 15.0.0)
        /usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 227.0.0) 
        /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 550.44.0)
        /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices (compatibility version 1.0.0, current version 38.0.0)
        /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 751.63.0)
        /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 1038.36.0)

Versions:
Alien::SDL 1.438
SDL 2.54

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.