New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't start on MacOS #62

Closed
mdblabs opened this Issue Nov 23, 2017 · 10 comments

Comments

Projects
None yet
2 participants
@mdblabs

mdblabs commented Nov 23, 2017

Hi,
I have downloaded last Phaser Editor version for MacOS and it doesn't start. Only error message: "It cannot start".

I'm running MacOS Sierra. Any idea?

Edit:
More details, about my java version:
java version "1.8.0_111" Java(TM) SE Runtime Environment (build 1.8.0_111-b14) Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)

Thanks!

@PhaserEditor2D

This comment has been minimized.

Show comment
Hide comment
@PhaserEditor2D

PhaserEditor2D Nov 23, 2017

Owner

The only thing that comes to my mind is that it is not using the Java bundled with the editor. Let me google a bit.

Owner

PhaserEditor2D commented Nov 23, 2017

The only thing that comes to my mind is that it is not using the Java bundled with the editor. Let me google a bit.

@PhaserEditor2D

This comment has been minimized.

Show comment
Hide comment
@PhaserEditor2D

PhaserEditor2D Nov 23, 2017

Owner

You just unpacked the zip and clicked on the Phaser Editor.app?

Owner

PhaserEditor2D commented Nov 23, 2017

You just unpacked the zip and clicked on the Phaser Editor.app?

@PhaserEditor2D

This comment has been minimized.

Show comment
Hide comment
@PhaserEditor2D

PhaserEditor2D Nov 23, 2017

Owner

Also, try by opening the terminal:

cd "/path/to/Phaser Editor.app/Contents/MacOS"
./PhaserEditor
Owner

PhaserEditor2D commented Nov 23, 2017

Also, try by opening the terminal:

cd "/path/to/Phaser Editor.app/Contents/MacOS"
./PhaserEditor
@mdblabs

This comment has been minimized.

Show comment
Hide comment
@mdblabs

mdblabs Nov 23, 2017

Yep, directly extracted from the zip.
More info:

ls -la
drwx------         102  2 nov 22:41 Phaser Editor.app
-rw-r--r--@       389630204 23 nov 20:18 Phaser-Editor-1.4.3.GA.jre.macosx.zip

Trying to execute:

./Phaser\ Editor.app/
-bash: ./Phaser Editor.app/: is a directory

mdblabs commented Nov 23, 2017

Yep, directly extracted from the zip.
More info:

ls -la
drwx------         102  2 nov 22:41 Phaser Editor.app
-rw-r--r--@       389630204 23 nov 20:18 Phaser-Editor-1.4.3.GA.jre.macosx.zip

Trying to execute:

./Phaser\ Editor.app/
-bash: ./Phaser Editor.app/: is a directory
@PhaserEditor2D

This comment has been minimized.

Show comment
Hide comment
@PhaserEditor2D

PhaserEditor2D Nov 23, 2017

Owner

You cannot execute a directory, you need to go into Phaser Editor.app/Contents/MacOS and execute PhaserEditor.

Owner

PhaserEditor2D commented Nov 23, 2017

You cannot execute a directory, you need to go into Phaser Editor.app/Contents/MacOS and execute PhaserEditor.

@mdblabs

This comment has been minimized.

Show comment
Hide comment
@mdblabs

mdblabs Nov 23, 2017

Ok, solved! Was a permissions issue.

ls -la
-rw-r--r--   PhaserEditor
drwx------  jre
./PhaserEditor
-bash: ./PhaserEditor: Permission denied
chmod 755 PhaserEditor
./PhaserEditor
Plugin.start phasereditor.lic...

Now I can start it directly from the .app. Thanks!

mdblabs commented Nov 23, 2017

Ok, solved! Was a permissions issue.

ls -la
-rw-r--r--   PhaserEditor
drwx------  jre
./PhaserEditor
-bash: ./PhaserEditor: Permission denied
chmod 755 PhaserEditor
./PhaserEditor
Plugin.start phasereditor.lic...

Now I can start it directly from the .app. Thanks!

@mdblabs mdblabs closed this Nov 23, 2017

@PhaserEditor2D

This comment has been minimized.

Show comment
Hide comment
@PhaserEditor2D

PhaserEditor2D Nov 23, 2017

Owner

Oh, that's great!

And how did you add permission? do you think I need to include it in the documentation?

Owner

PhaserEditor2D commented Nov 23, 2017

Oh, that's great!

And how did you add permission? do you think I need to include it in the documentation?

@PhaserEditor2D

This comment has been minimized.

Show comment
Hide comment
@PhaserEditor2D

PhaserEditor2D Nov 23, 2017

Owner

Ah I see, chmod 775

Owner

PhaserEditor2D commented Nov 23, 2017

Ah I see, chmod 775

@mdblabs

This comment has been minimized.

Show comment
Hide comment
@mdblabs

mdblabs Nov 23, 2017

Normally, you should pack it including permissions. That way, them will be kept over systems. Note: only if packed from a *nix system.

mdblabs commented Nov 23, 2017

Normally, you should pack it including permissions. That way, them will be kept over systems. Note: only if packed from a *nix system.

@PhaserEditor2D

This comment has been minimized.

Show comment
Hide comment
@PhaserEditor2D

PhaserEditor2D Nov 23, 2017

Owner

Ok thanks!

Owner

PhaserEditor2D commented Nov 23, 2017

Ok thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment